Bug 1058018 - upgrade from 3.3 overwrites exports with acl None
Summary: upgrade from 3.3 overwrites exports with acl None
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: bugs@ovirt.org
URL:
Whiteboard: integration
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-01-26 13:26 UTC by Yedidyah Bar David
Modified: 2014-03-31 12:25 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:25:14 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24468 0 None MERGED packaging: setup: remove: do not touch file if not changed 2020-10-13 10:30:43 UTC
oVirt gerrit 24469 0 None MERGED packaging: setup: remove: first remove files, then content 2020-10-13 10:30:42 UTC
oVirt gerrit 24470 0 None MERGED packaging: setup: cleanup nfs exports usage 2020-10-13 10:30:42 UTC
oVirt gerrit 24831 0 None MERGED packaging: setup: cleanup nfs exports usage 2020-10-13 10:30:43 UTC

Description Yedidyah Bar David 2014-01-26 13:26:29 UTC
Description of problem:

On upgrade from 3.3, iso domain export line is overwritten with an ACL 'None'

Version-Release number of selected component (if applicable):

3.4.0-beta

How reproducible:

Always

Steps to Reproduce:
1. setup 3.3.2 with an iso domain
2. upgrade to 3.4.0-beta
3.

Actual results:

The nfs export line is overwritten with acl set to 'None'

Expected results:

Line should not change

Additional info:

Reported on users@ by Jonathan Archer.

Comment 1 Alon Bar-Lev 2014-02-13 23:11:39 UTC
commit 9a43a775bfb9a25a88c387bbfeebbca8f2388715
Author: Alon Bar-Lev <alonbl@redhat.com>
Date:   Thu Feb 13 01:24:34 2014 +0200

    packaging: setup: cleanup nfs exports usage
    
    1. if exports.d exists and we registered ourselves previously in
       exports, move the entry to our own file.
    
    2. if ACL specified enforce a new entry.
    
    3. do not touch anything on upgrade unless (2).
    
    Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1058018
    Change-Id: Ie3df61b1b52aead5ddf457da14f26324dbc2a56c
    Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>

Comment 2 Sandro Bonazzola 2014-02-24 08:15:36 UTC
Shouldn't this be in modified?

Comment 3 Alon Bar-Lev 2014-02-24 10:05:36 UTC
yes

Comment 4 Sandro Bonazzola 2014-03-03 14:40:41 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 5 Sandro Bonazzola 2014-03-31 12:25:14 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.