Bug 105803 - .Xdefaults needs to be loaded by hand in order for setings to work
.Xdefaults needs to be loaded by hand in order for setings to work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-27 16:06 EDT by ajs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 16:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajs 2003-09-27 16:06:06 EDT
Description of problem:
When starting XEmacs for the first time after logging in, I have to load
.Xdefaults by hand in order for my color settings to be applied.  All of the
other programs that I use a GTK applications, so I don't know if this affect
other programs or not.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-33

How reproducible:
Always

Steps to Reproduce:
1. Make sure that there are lines like
     emacs*Background: DarkSlateGray
     emacs*Foreground: Wheat
   in your .Xdefaults
2. Log out and restart X
3. Log back in
4. 'xemacs ~/.Xdefaults'
    
Actual results:
The colors used by xemacs are not correct
Comment 1 Mike A. Harris 2003-09-29 16:39:06 EDT
Xdefaults was deprecated about 4 years ago.  We included support for Xdefaults
for an additional few OS releases as a backward compatibility convenience,
however Xdefaults support has been removed from XFree86 upstream and from
Red Hat Linux for a couple of years now, replaced with Xresources instead.
If you require assistance transitioning to Xresources, please consult the
XFree86@xfree86.org mailing list for help.
Comment 2 ajs 2003-10-16 15:14:43 EDT
It turns out the real problem was related to a recent change in the sorting
method that xrdb uses (from where I don't know).

I had a symlink to .Xresources from .Xdefaults because I used to have to share
my home directory with a several other *nix variants and old habits die hard.

The lines that brought things to my attention were
  emacs*Background:	gray80
  emacs*Foreground:	black

These used to work until at least RH 9 and I think (but won't swear to) severn
1.  Because .Xresources is merged and somewhere upstream the background was
being set for Emacs*, when the sorting method changed, my settings wern't being
applied.  xrdb -load would work because options were being replaced.  Changing
the lines in .Xresources to 
  Emacs*Background:	gray80
  Emacs*Foreground:	black
fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.