Bug 105813 - cannot enter new hosts and it doesn't show current hosts
Summary: cannot enter new hosts and it doesn't show current hosts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: beta2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 00:59 UTC by Santiago Erquicia
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 14:09:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Santiago Erquicia 2003-09-28 00:59:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/1.0

Description of problem:
When I try to enter a new host (because I was changing the name of the machine),
it asks the required information but when I add everything nothing happens.

When I try to close the application it asks if I want to save the changes.

After doing this by hand, editing /etc/hosts, it redhat-config-network doesn't
show what /etc/hosts says

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.6-1

How reproducible:
Always

Steps to Reproduce:
1.open redhat-config-network
2.add a new host
3.press ok after entering the required information
    

Actual Results:  nothing happens (I don't know if the changes are made but it
doesn't show them)

Expected Results:  The information entered is shown in the application

Additional info:

Comment 1 Santiago Erquicia 2003-09-28 01:15:41 UTC
I am checking right now that after I made the changes at /etc/sysconfig/network
to change my hostname, redhat-config-network doesn't update it.  It keeps saying
localhost.localdomain, and when I try to close the application it asks about
applying the changes although this time I didn't anyone within the application

Comment 2 Dave Habben 2003-10-10 14:49:57 UTC
Works for me with an updated redhat-config-network:
redhat-config-network-1.3.7-1

Care to try again with the updated version? Otherwise this should probably be
marked as RAWHIDE/CLOSED


Comment 3 Santiago Erquicia 2003-10-10 15:04:42 UTC
It keeps the same way with the updated redhat-config-network (1.3.7-1).

My /etc/sysconfig/networking/profiles/default/hosts says
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1	localhost.localdomain	localhost
127.0.0.1	argentina	

And nothing shows it the hosts tab under the application.  I did that by hand.

Comment 4 Dave Habben 2003-10-10 15:29:14 UTC
There is code in this file that intentionally skips 127.0.0.1 addresses:
/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py

for host in prof.HostsList:
  #88357
  if host.IP == "127.0.0.1":
      continue

I tried commenting that out and it displayed the 127.0.0.1 addresses correctly,
I'm thinking this is probably by design.




Note You need to log in before you can comment on or make changes to this bug.