Bug 1058224 - the system cache should be world readable by default
the system cache should be world readable by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-27 04:32 EST by Elad Alfassa
Modified: 2014-03-07 22:35 EST (History)
5 users (show)

See Also:
Fixed In Version: dnf-0.4.17-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 22:35:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad Alfassa 2014-01-27 04:32:28 EST
[elad@rincewind dnf]$ dnf grouplist --cacheonly
[Errno 13] Permission denied: '/var/cache/dnf/x86_64/20/fedora/repodata/gen'
Comment 1 Parag Nemade 2014-01-27 04:42:39 EST
I think it needs a root user access.
Comment 2 Elad Alfassa 2014-01-27 04:44:03 EST
That's silly. It's a read only command and I explicitly specified --cacheonly, which means "Don't download metadata, use existing cache".
Comment 3 Ales Kozumplik 2014-01-27 04:51:31 EST
yes, it's what it does: it's trying to use the root cache, see the manual. the root cache is created with permissions given by root's umask. if you change the permissions on the root cahe to be readable by the user (safe) all should be fine.
Comment 4 Elad Alfassa 2014-01-27 04:54:35 EST
Why is this the default?
Comment 5 Ales Kozumplik 2014-01-27 05:00:54 EST
Hmm, actually I think you might be right, this should be world-readable, at least until somebody starts to complain. We'll take a look at this.
Comment 6 Honza Silhan 2014-02-27 10:31:49 EST
System cache was readable by user. The problem was during decompression of xmls into root directory. Fixed in the upstream.
Comment 7 Fedora Update System 2014-03-05 07:57:14 EST
dnf-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.17-1.fc20
Comment 8 Fedora Update System 2014-03-06 03:13:54 EST
Package dnf-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3465/dnf-0.4.17-1.fc20
then log in and leave karma (feedback).
Comment 9 Tim Lauridsen 2014-03-07 03:07:06 EST
dnf grouplist --cacheonly
Error: This command has to be run under the root user.

dnf grouplist --cacheonly --noplugins

works

the initial problem is solved, but looks like the noroot plugin
has an issue in this case.
Comment 10 Fedora Update System 2014-03-07 22:35:15 EST
dnf-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.