Bug 1058289 - FTBFS: omelasticsearch.c:611:39: error: 'mutHTTPReqFail' undeclared (first use in this function)
Summary: FTBFS: omelasticsearch.c:611:39: error: 'mutHTTPReqFail' undeclared (first us...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog
Version: rawhide
Hardware: powerpc
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tomas Heinrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1061319 (view as bug list)
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-01-27 12:55 UTC by Karsten Hopp
Modified: 2016-09-20 04:51 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-02-13 13:18:16 UTC


Attachments (Terms of Use)
updated package (2.81 MB, application/octet-stream)
2014-02-09 20:42 UTC, Tomas Heinrich
no flags Details

Description Karsten Hopp 2014-01-27 12:55:04 UTC
Description of problem:
make[2]: Entering directory `/builddir/build/BUILD/rsyslog-7.4.7/plugins/omelasticsearch'
  CC     omelasticsearch_la-omelasticsearch.lo
In file included from ../../runtime/prop.h:25:0,
                 from ../../runtime/glbl.h:35,
                 from ../../runtime/stream.h:70,
                 from ../../runtime/obj.h:48,
                 from ../../runtime/rsyslog.h:525,
                 from omelasticsearch.c:26:
omelasticsearch.c: In function 'curlPost':
omelasticsearch.c:611:39: error: 'mutHTTPReqFail' undeclared (first use in this function)
    STATSCOUNTER_INC(indexHTTPReqFail, mutHTTPReqFail);
                                       ^
../../runtime/atomic.h:205:22: note: in definition of macro 'ATOMIC_INC_uint64'
   pthread_mutex_lock(phlpmut); \
                      ^
omelasticsearch.c:611:4: note: in expansion of macro 'STATSCOUNTER_INC'
    STATSCOUNTER_INC(indexHTTPReqFail, mutHTTPReqFail);
    ^
omelasticsearch.c:611:39: note: each undeclared identifier is reported only once for each function it appears in
    STATSCOUNTER_INC(indexHTTPReqFail, mutHTTPReqFail);
                                       ^
../../runtime/atomic.h:205:22: note: in definition of macro 'ATOMIC_INC_uint64'
   pthread_mutex_lock(phlpmut); \
                      ^
omelasticsearch.c:611:4: note: in expansion of macro 'STATSCOUNTER_INC'
    STATSCOUNTER_INC(indexHTTPReqFail, mutHTTPReqFail);
    ^
omelasticsearch.c: In function 'modInit':
omelasticsearch.c:1004:33: error: 'mutCtrIndexSubmit' undeclared (first use in this function)
  STATSCOUNTER_INIT(indexSubmit, mutCtrIndexSubmit);
                                 ^
../../runtime/atomic.h:225:59: note: in definition of macro 'INIT_ATOMIC_HELPER_MUT64'
 # define INIT_ATOMIC_HELPER_MUT64(x) pthread_mutex_init(&(x), NULL)
                                                           ^
omelasticsearch.c:1004:2: note: in expansion of macro 'STATSCOUNTER_INIT'
  STATSCOUNTER_INIT(indexSubmit, mutCtrIndexSubmit);
  ^
omelasticsearch.c:1007:35: error: 'mutCtrIndexHTTPFail' undeclared (first use in this function)
  STATSCOUNTER_INIT(indexHTTPFail, mutCtrIndexHTTPFail);
                                   ^
../../runtime/atomic.h:225:59: note: in definition of macro 'INIT_ATOMIC_HELPER_MUT64'
 # define INIT_ATOMIC_HELPER_MUT64(x) pthread_mutex_init(&(x), NULL)
                                                           ^
omelasticsearch.c:1007:2: note: in expansion of macro 'STATSCOUNTER_INIT'
  STATSCOUNTER_INIT(indexHTTPFail, mutCtrIndexHTTPFail);
  ^
omelasticsearch.c:1010:38: error: 'mutCtrIndexHTTPReqFail' undeclared (first use in this function)
  STATSCOUNTER_INIT(indexHTTPReqFail, mutCtrIndexHTTPReqFail);
                                      ^
../../runtime/atomic.h:225:59: note: in definition of macro 'INIT_ATOMIC_HELPER_MUT64'
 # define INIT_ATOMIC_HELPER_MUT64(x) pthread_mutex_init(&(x), NULL)
                                                           ^
omelasticsearch.c:1010:2: note: in expansion of macro 'STATSCOUNTER_INIT'
  STATSCOUNTER_INIT(indexHTTPReqFail, mutCtrIndexHTTPReqFail);
  ^
omelasticsearch.c:1013:33: error: 'mutCtrIndexESFail' undeclared (first use in this function)
  STATSCOUNTER_INIT(indexESFail, mutCtrIndexESFail);
                                 ^
../../runtime/atomic.h:225:59: note: in definition of macro 'INIT_ATOMIC_HELPER_MUT64'
 # define INIT_ATOMIC_HELPER_MUT64(x) pthread_mutex_init(&(x), NULL)
                                                           ^
omelasticsearch.c:1013:2: note: in expansion of macro 'STATSCOUNTER_INIT'
  STATSCOUNTER_INIT(indexESFail, mutCtrIndexESFail);
  ^
make[2]: *** [omelasticsearch_la-omelasticsearch.lo] Error 1

Version-Release number of selected component (if applicable):
rsyslog-7.4.7-1.fc21

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f21 rsyslog-7.4.7-1.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1626688

Expected results:


Additional info:

Comment 1 Karsten Hopp 2014-02-09 10:15:02 UTC
Any news here ? This is becoming urgent as rsyslog gets pulled into the buildroots of more than 750 other packages and is blocking those builds.

I can give you access to a PPC machine if that would help. Just send me your public ssh key and reference this bugzilla in the mail.

Comment 2 Tomas Heinrich 2014-02-09 20:42:13 UTC
Created attachment 861133 [details]
updated package

Here's a patched srpm. If you can confirm it builds cleanly, I'll push the change with the next update. (Which should happen soon.)

Comment 3 Karsten Hopp 2014-02-13 13:18:16 UTC
Thanks a lot for that srpm. A scratch build succeeded.
But it looks like an update isn't necessary anymore, Lubomir Rintel has already built a new version: http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=219966

Comment 4 Tomas Heinrich 2014-02-13 13:53:59 UTC
*** Bug 1061319 has been marked as a duplicate of this bug. ***

Comment 5 Tomas Heinrich 2014-02-13 13:57:23 UTC
(In reply to Karsten Hopp from comment #3)
> Thanks a lot for that srpm. A scratch build succeeded.
> But it looks like an update isn't necessary anymore, Lubomir Rintel has
> already built a new version:
> http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=219966

Yeah, he beat me to it.
Good to hear it builds for you.


Note You need to log in before you can comment on or make changes to this bug.