Bug 105830 - installer detects and use second CD Reader but fail to umount
installer detects and use second CD Reader but fail to umount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 05:50 EDT by Daniel Veillard
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 23:25:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Veillard 2003-09-28 05:50:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
  Hum, I managed to break the installer
    - boot with CD Rom1 in hda reader
    - put CD Rom 2 in hdc reader
    - anaconda automatically find and load CD2 from hdc
    - but when trying to eject CD Rom 2 it loops in error
      "an error unmounting the CD, please make sure you're not
       accessing /mnt/source from the shell"
      and it's impossible to get out of the loop from the UI
      (fiddling on tty2 to remmount the CD on hda was the only way)


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.boot with CD Rom1 in hda reader
2.put CD Rom 2 in hdc reader
3.anaconda automatically find and load CD2 from hdc
4.anaconda fails ejecting from hdc
    

Actual Results:  anaconda fails ejecting from hdc at the end of CD2

Expected Results:  anaconda to eject from hdc it it was mounted from it
and continue with CD3 from either hda or hdc

Additional info:
Comment 1 Michael Fulbright 2003-09-29 11:04:58 EDT
If you switch to VC2 and look at /tmp/syslog do you see any kernel read errors
that might be from the CD?
Comment 2 Daniel Veillard 2003-09-29 12:00:52 EDT
No read error. The /mnt/source was unmounted. But apparently somewhere
anaconda thought that it was hda and not hdc to umount and eject and got
confused. Only way was to remove the CD from hdc, put it back in hda
mount it on /tmp/hda (after mknod /tmp/hda) and then the installation
could resume.
The problem is that somewhere inside anaconda was still expecting 
/mnt/source to be mounted from the primary CDRom used for boot and not
the secondary one used to read Disk2

Daniel
Comment 3 Daniel Veillard 2003-09-29 12:01:42 EDT
of course I did the install yeesterday and the /tmp/syslog is long gone :-\

Daniel
Comment 4 Jeremy Katz 2004-02-11 18:45:18 EST
Does this happen with the final RHEL release?
Comment 5 Daniel Veillard 2004-02-12 04:54:03 EST
Hum, I didn't tried to reproduce the behaviour. I have an
RHEL 3 AS installed on that box now. I can't be 100% sure the
problem occured with the beta2 media, I think that was the
latest option available at the time though I burned the CD myself
probably with later versions. 

Daniel
Comment 6 Jeremy Katz 2004-11-30 23:25:14 EST
This should be fine in current code, AFAIK.  Reopen if you can reproduce on a
recent FC/RHEL build.

Note You need to log in before you can comment on or make changes to this bug.