Bug 105831 - Anaconda install fails without virtual terminals
Anaconda install fails without virtual terminals
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 06:09 EDT by Eric Knudstrup
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 16:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Knudstrup 2003-09-28 06:09:53 EDT
Description of problem:
I am trying to install RedHat9 on a system without a VGA card and had to create 
a custom kernel to be able to install on it (http://www.soekris.com)

Version-Release number of selected component (if applicable): 9


How reproducible:  Build a kernel with serial console (no virtual terminal 
support) only and try to install RH9 on it.


Steps to Reproduce:
1.  Attempt to install RH9 booting from a kernel without virtual terminals
2.
3.
    
Actual results:
Anaconda barfs on exception because tty5 doesn't exist

Expected results:
Everything is happy, installs cleanly, as a result I am happy

Additional info:
Comment 1 Eric Knudstrup 2003-09-28 06:14:35 EDT
Backtrace:



          +---------------+ Checking for Bad Blocks +---------------+
          |                                                         |
          | Checking for bad blocks on /dev/hda5...                 |
          |                                                         |
          |                            0%                           |
          |                                                         |
          +---------------------------------------------------------+








Traceback (most recent call last):
  File "/usr/bin/anaconda", line 739, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/text.py", line 
459, in run
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/dispatch.py", line 
157, in gotoNext
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/dispatch.py", line 
225, in moveStep
  File "/tmp/updates/packages.py", line 463, in turnOnFilesystems
    thefsset.checkBadblocks(instPath)
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/fsset.py", line 
1102, in checkBadblocks
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/fsset.py", line 
1079, in badblocksEntry
  File "/usr/src/build/229094-i386/install//usr/lib/anaconda/fsset.py", line 
186, in badblocksDevice
OSError: [Errno 19] No such device: '/dev/tty5'

> /usr/src/build/229094-i386/install/usr/lib/anaconda/fsset.py(186)
badblocksDevice()

******end of dump******

BTW, it would be nice if you'd put NatSemi Geode support into your kernel :):
http://www.sk-tech.net/support/net4801/net4801.kernel.patch
And it would also be nice if there were a pxeboot vmlinuz and initrd for serial 
only (ie embedded) systems :).

Thanks,

Eric
Comment 2 Jeremy Katz 2003-09-29 16:23:18 EDT
anaconda only supports working if you have virtual terminal support in your
kernel (even if it's not being used)

Note You need to log in before you can comment on or make changes to this bug.