Bug 105833 - bad source code
bad source code
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdeaddons (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 114745 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 06:52 EDT by d.binderman
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 05:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-09-28 06:52:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package kdeaddons-3.1-4 from
Redhat 9.0 with compiler flag -Wall.

The compiler said

display.c:121: warning: operation on `pdest' may be undefined

The source code is

                            *(pdest++)=*(pdest-1);

This code is undefined.

You would be much better off with

		*pdest = pdest[ -1];
		++pdest;



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with compiler flag -Wall
2.
3.
    

Additional info
Comment 1 Ngo Than 2004-04-07 18:04:23 EDT
*** Bug 114745 has been marked as a duplicate of this bug. ***
Comment 2 Ngo Than 2004-06-28 05:14:47 EDT
i have forwarded it to the maintainer. I hope it will be included in
next upstream. Thanks for your report.
Comment 3 David Binderman 2005-02-18 07:38:19 EST
>I hope it will be included in next upstream

Still broken in February 2005, some 17 months after 
the original report.

Note You need to log in before you can comment on or make changes to this bug.