Bug 105836 - kdemultimedia bad source code
Summary: kdemultimedia bad source code
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 11:05 UTC by d.binderman
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 15:30:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-09-28 11:05:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I have just tried to compile package kdemultimedia-3.1-4 from Redhat 9.0
with the compiler flag -Wall. The compiler said

resample.c:1288: warning: operation on `dest' may be undefined
resample.c:1289: warning: operation on `dest' may be undefined

The source code is

  *dest++ = *(dest - 1) / 2;
  *dest++ = *(dest - 1) / 2;

Better source code would be

  *dest = *(dest - 1) / 2;
  ++dest;
  *dest = *(dest - 1) / 2;
  ++dest;

Also, the compiler said

cdtext.c:211: warning: `return' with no value, in function returning non-void
cdtext.c:402: warning: this function may return with or without a value


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with flag -Wall.
2.
3.
    

Additional info

Comment 1 Ngo Than 2004-06-03 15:30:10 UTC
it seems to be fixed in kde 3.2.x.


Note You need to log in before you can comment on or make changes to this bug.