Bug 105837 - kon2 bad source code
Summary: kon2 bad source code
Status: CLOSED DUPLICATE of bug 78705
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kon2 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 11:08 UTC by d.binderman
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-09-28 11:08:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package kon2-0.3.9b-16 from Redhat 9.0,
with compiler flag -Wall.

The compiler said

mkminifont.c:28: warning: too few arguments for format


The source code is

        printf("usage: %s [minix font file]\n");

Clearly wrong. You might be better off with

        printf("usage: %s [minix font file]\n", argv[ 0]);


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with flag -Wall
2.
3.
    

Additional info

Comment 1 Akira TAGOH 2003-09-29 06:21:31 UTC
I'm wondering if you read the e-mail from bugzilla

*** This bug has been marked as a duplicate of 78705 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.