Bug 1058383 - Scrolling using keyboard in All Available Subscriptions does not visually scroll
Summary: Scrolling using keyboard in All Available Subscriptions does not visually scroll
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-01-27 17:15 UTC by Sharath Dwaral
Modified: 2015-03-23 01:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:46:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Sharath Dwaral 2014-01-27 17:15:39 UTC
Description of problem:
Scrolling using keyboard in All Available Subscriptions does not visually scroll

Version-Release number of selected component (if applicable):
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.2-1
subscription-manager: 1.10.11-1.el7
python-rhsm: 1.10.11-1.el7


How reproducible:
Always

Steps to Reproduce:
1. Register Sub-man to candlepin
2. Goto All Available Subscription Tab and click Update
3. Select a subscription and try scrolling using keyboard arrows

Actual results:
The subscriptions are selected but visual scrolling does not happen

Expected results:
The scroll bar should move and visually scroll when scrolling

Additional info:

Comment 1 John Sefler 2014-01-28 19:19:37 UTC
Also fails in System > Repositories list.

Does NOT fail on My Installed Products list.
Does NOT fail on My Subscriptions list.
Does NOT fail on System > View System Facts list.

Comment 4 Carter Kozak 2014-05-09 14:45:40 UTC
commit 9d35a5fb831563c64514d50425dea9537a7765c7
Author: ckozak <ckozak@redhat.com>
Date:   Wed Mar 5 10:28:12 2014 -0500

    1058383: widgets are added and removed dynamically
    
    This is better than using nested containers and using show/hide
    because we allow the GtkTreeView to handle its own scrolling,
    while the GtkLabel is handled by a GtkViewPort
    
    With a container housing multiple widgets, one could move the
    selected subscription row (with arrow keys) beyond the top or
    bottom of the scrollable pane.

Comment 6 Shwetha Kallesh 2014-06-20 09:37:30 UTC
Marking verified!! I see that its visually scrolling in both Available Subscription Tab and Repositories list with following version.

[root@dhcp-0-177 ~]# subscription-manager version
server type: RHN Classic and Red Hat Subscription Management
subscription management server: 0.9.19-1
subscription management rules: 5.9
subscription-manager: 1.12.4-1.el6
python-rhsm: 1.12.3-1.git.0.526cd89.el6

Comment 8 errata-xmlrpc 2014-10-14 07:46:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.