Bug 105839 - libungif bad source code
libungif bad source code
Status: CLOSED DUPLICATE of bug 78707
Product: Red Hat Linux
Classification: Retired
Component: libungif (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-09-28 07:14 EDT by d.binderman
Modified: 2013-04-02 00:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-09-28 07:14:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package libungif-4.1.0-15 from Radhat 9.0
with compiler option -Wall.

The compiler said

gifinfo.c:163: warning: too few arguments for format

The source code is

                    fprintf(stderr, "Image %d is not confined to screen dimension, aborted.\n");

Sounds like a missing number for the %d to me.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. compile with -Wall.

Additional info
Comment 1 Jef Spaleta 2004-02-25 11:18:40 EST
Even though this is a newer package, the same warning is being generated
from the same line in the gifinfo.c file, so i'm going to mark this as a 
duplicate of the bug from the older package.

*** This bug has been marked as a duplicate of 78707 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.