Bug 10584 - RedHat 6.2 (Sparc) installation hangs during post install step on Axi
RedHat 6.2 (Sparc) installation hangs during post install step on Axi
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-04 14:40 EDT by govind.vaidya
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 14:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description govind.vaidya 2000-04-04 14:40:26 EDT
We are filing this report per request from Glen Foster:

Description of the problem
--------------------------
While installing (in default mode) RedHat 6.2 on Axi UltraSparc system,
the install process hangs while performing 'post install steps'.
Same problem was seen when we tried 'text mode' option.

---------------------
Date: Mon, 03 Apr 2000 12:12:15 -0400
From: "Glen A. Foster" <glen@redhat.com>
X-Accept-Language: en
MIME-Version: 1.0
To: Tuan Le <Tuan.Le@eng.sun.com>
CC: Erik Troan <ewt@redhat.com>, sharma@pixels.Eng.Sun.COM,
amod.patwardhan@eng.sun.com, timothy.mooney@eng.sun.com
Subject: Re: (Sparc) Red Hat Linux 6.2 (Zoot)
Content-Transfer-Encoding: 7bit

........

	[1] Someone from Sun should file all bug reports with
		"bugzilla", our defect-tracking mechanism; we will
		see what can be done in the near-term so that
		perhaps a set of defect fixes can be made available
		soon, as I would like your customers to be able to
		install (and use!) Red Hat Linux 6.2
.........

Glen
--------------------------------------------
Comment 1 Glen Foster 2000-04-05 10:09:59 EDT
Govind, thanks for filing this defect report; now it's trackable.  Also, we
have been unsuccessful in reproducing the hang.  We have had success with the
following installation configurations, all using a single file system ("/"):

[1] An "Everything" install (6.2) from FTP media
[2] An "Everything" install (6.2) from CD
[3] An "Everything" install (6.1 base) upgraded to 6.2 over NFS

Is there some special configuration you choose (GNOME or KDE workstation,
server, custom install, etc.) that shows the problem (vs the ones above)?

Also, in case there's a hardware difference/problem, here are the pertinent
parts of the AXi loaner system we have here:

(a) 300MHz UltraSPARC IIi CPU
(b) 8.7GB SCSI hard drive
(c) SCSI CD-ROM drive
(d) 3D RAGE II video controller with 4MB RAM
(e) HAPPY MEAL ethernet controller
Comment 2 govind.vaidya 2000-04-05 14:45:59 EDT
We have tried on Axi clone (Rave System) which has same h/w configuration as
your system mentioned above. The problem is reproducable on it.

Following are the install options:

1. Installing from local CDROM.
2. Selected "Everything" through custom install option.
3. Disk has two partitions, 256MB swap and rest is allocated to root partition.
Comment 3 Brock Organ 2000-04-12 12:47:59 EDT
this behavior is duplicated for the following conditions:

install using cdrom, and at the network config screen enter:

choose static config (no dhcp) ...
enter ip address ...
accept defaults for network, netmask, broadcast ...

explicitly enter a hostname
explicitly enter the ip of a gateway in a different sub-net from the static ip
...
explicitly enter the primary dns in a different sub-net from the static ip ...

proceed with the install; during the post-install screen an anaconda traceback
occurs:

Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap self.run()
  File "/usr/lib/anaconda/iw/progress.py", line 16, in run rc =
self.todo.doInstall()
  File "/usr/lib/anaconda/todo.py", line 1252, in doInstall
self.writeConfiguration()
  File "/usr/lib/anaconda/todo.py", line 1065, in writeConfiguration
self.writeNetworkConfig ip = self.network.lookupHostname()
  File "/usr/lib/anaconda/todo.py", line 531, in writeNetworkConfig ip =
self.network.lookupHostname()
  File "/usr/lib/anaconda/todo.py", line 144, in lookupHostname self.gateway)
  File "/usr/lib/anaconda/isys.py", line 230, in configNetDevice return
_isys.confignetdevice(device,ip,netmask,gw)
SystemError: (51, 'Network is unreachable')
Comment 4 Glen Foster 2000-04-12 16:36:59 EDT
The actual problem for this defect should be formally changed here.  The problem
is that the installer does not gracefully handle the case where a gateway and/or
DNS server cannot be reached to verify a hostname entered in the network
configuration screen (such as gateway and DNS on different subnet from the local
IP address).
Comment 5 Anonymous 2000-04-14 00:54:59 EDT
I am seeing the same problem using the Redhat6.2 i386 ISO image.  No matter
what configuration I try, I still hang at "Performing post install
configuration".  I am using an Abit BE6.0 rev.2 board, 128mb ram, 2gb SCSI
drive partioned with 1900M as "slash" and 141M as "swap".
Comment 6 Anonymous 2000-04-14 00:57:59 EDT
Reading further (sorry for the extra email and comments), Glen hit it right on
the nose.  I am behind a firewall with IP 192.168.1.x, and trying to get DNS
services from 24.0.X.X from beyond the firewall.

My apologies.
Charles
Comment 7 dave 2000-06-11 00:03:40 EDT
I'm having the exact same problem. I can boot from a rescue disk, how do I go 
about finishing the install cleanly? Is there some post install script I can 
run from the CD?

dave@ci.bryan.tx.us

Note You need to log in before you can comment on or make changes to this bug.