This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 105840 - mysql bad source code
mysql bad source code
Status: CLOSED DUPLICATE of bug 82189
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 07:17 EDT by d.binderman
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-09-28 07:17:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package mysql-3.23.54a-11 from Redhat 9.0
with compiler flag -Wall.

The compiler said

log0recv.c:1384: warning: too few arguments for format
log0recv.c:1401: warning: too few arguments for format
log0recv.c:1429: warning: too few arguments for format

The source codes are

                                printf(
"InnoDB: Error: cannot open %lu'th data file %s\n", nth_file);

and
                                printf(
"InnoDB: Error: cannot read page no %lu from %lu'th data file %s\n",
                                nth_page_in_file, nth_file);

and
                                printf(
"InnoDB: Error: cannot write page no %lu to %lu'th data file %s\n",
                                nth_page_in_file, nth_file);


All these printf statements are clearly wrong at compile time.
You may consider it prudent to fix them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with -Wall.
2.
3.
    

Additional info
Comment 1 Patrick Macdonald 2003-09-29 09:54:32 EDT
This is a duplicate of bug #82189 (which you opened against 8.0).  Anyway, the
MySQL folks are aware of the problem, have patched it in 4.0 but do not feel
the need to patch it in 3.23.x.  Please refer to 82189 for the proper MySQL
bug.

*** This bug has been marked as a duplicate of 82189 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.