Bug 105843 - nvi-m17n bad source code
nvi-m17n bad source code
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nvi-m17n (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 07:23 EDT by d.binderman
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: 1.79-20011024.15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-20 08:22:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-09-28 07:23:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package nvi-m17n-1.79-20011024.10
from Redhat 9.0 with compiler flag -Wall.

The compiler said

../ex/ex_txt.c:420: warning: operation on `scno' may be undefined

The source code is

        scno -= --scno % sw;

Clearly wrong. Better

        --scno;
        scno -= scno % sw;

Even though it is important to worry about scno going negative, 
and then getting undefined answers.

Also, the compiler said

../vi/v_txt.c:2173: warning: operation on `target' may be undefined

and

../common/multi_iso2022.c:1141: warning: operation on `p' may be undefined

Looks like quite a bit of undefined code.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile with -Wall.
2.
3.
    

Additional info
Comment 1 Akira TAGOH 2003-10-20 08:22:25 EDT
fixed in 1.79-20011024.15.

Note You need to log in before you can comment on or make changes to this bug.