Bug 105852 - buggy mailFrom setting
Summary: buggy mailFrom setting
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diskcheck   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 109527 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 12:50 UTC by Adam Spiers
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 10:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Spiers 2003-09-28 12:50:46 UTC
The default From: header in mails sent out by diskcheck
("Disk Usage Monitor - diskcheck") confuses the MDA (Postfix
in this case), so that the header arrives at its destination
like this:

From: Disk@my.domain.com, Usage@my.domain.com,
        Monitor@my.domain.com, -@my.domain.com,
        diskcheck@my.domain.com

(I have postfix forwarding root mail to a remote machine,
which also runs postfix.)

Version-Release number of selected component (if applicable):
diskcheck-1.4-2 and diskcheck-1.4-4.1

Suggested fix:

Change line in diskcheck to read:

    set_default(conf, 'mailFrom', '"Disk Usage Monitor" <root>')

and change lines in diskcheck.conf to read:

    # Who to identify the mail as coming from.
    #mailFrom = '"Disk Usage Monitor - diskcheck"'

Comment 1 Harald Hoyer 2003-12-05 11:54:39 UTC
*** Bug 109527 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.