Bug 105879 - bootloader --useLilo --location=mbr causes hangup
bootloader --useLilo --location=mbr causes hangup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-28 18:47 EDT by Charles Curley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Curley 2003-09-28 18:47:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
Two related problems:

1) The symptom is that anaconda hangs at the point where the display console
indicates that the boot loader is being installed. Lilo has been removed from
Fedora Beta2. I conjecture that the Anaconda code still supports Lilo, but can't
find it to run it or some similar problem. 

2) Whatever the problems is, the python debug/error screen shows up on virtual
terminal 5 (<ctl><alt>F5), not the display terminal (<ctl><alt>F1). It is very
mangled, pssibly because of a terminal type mismatch (no ncurses??) This makes
it difficult to give details of 1) above.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Build a kickstart file with the following line:

bootloader --useLilo --location=mbr

2. Install.

3. See what happens during the post-install phase.    

Actual Results:  Anaconda hung as described.

Expected Results:  1) Since lilo is no longer in Fedora, either

* bomb out with a suitable error message -- the earlier the better in the
install process, please;

* offer the user the option of using grub;

* or go ahead and install grub instead of lilo anyway, preferably with a
blocking error message and a line in the install log.

Additional info:

Is it possible to parse kickstart files early in the festivities and alert the
user to unsupported/malformed options like this one?

At the time of the hangup, there are two python processes running (ps aux) but
neither one shows any increase in TIME (the penultimate column).

I encountered this while running the text installation, not the GUI installation.

My test bed machine is a PI @ ~133 MHZ, it takes a while to do an installation
even if I strip it down; that's why I haven't reproduced the problem.

The option --useLilo is essential; without it the install passes the boot loader
phase. Which means the workaround is obvious.

However, the problem of having the debug screen show up on the wrong virtual
terminal could be serious. If the user even knows to look for it, it is hard to
read, and may cost you debug information.
Comment 1 Jeremy Katz 2003-09-29 12:57:44 EDT
Added log message and made --useLilo a no-op

Note You need to log in before you can comment on or make changes to this bug.