Bug 1058958 - share from a Jolla device not properly mounted
Summary: share from a Jolla device not properly mounted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libmtp
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Linus Walleij
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-28 20:36 UTC by cetlorev
Modified: 2015-04-07 19:15 UTC (History)
2 users (show)

Fixed In Version: libmtp-1.1.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 05:04:00 UTC
Type: Bug


Attachments (Terms of Use)

Description cetlorev 2014-01-28 20:36:12 UTC
Description of problem:
When I connect a Jolla phone over usb to Fedora the MTP share is not properly mounted

Version-Release number of selected component (if applicable):
1.1.6-2.fc20

How reproducible:
Always

Steps to Reproduce:
1. Attach the Jolla phone with a usb cable to the computer
2. Select 'PC connection' on the phone
3. 

Actual results:
The share shows up in Files under Devices with the name Sailfish. But when selected the following error message is produced 'This location could not be displayed. Sorry, could not display all the contents of “Sailfish”: Failed to get folder list: -1: Unspecified error'

Expected results:
Be able to access the MTP share

Additional info:

If the share is mounted with the simple-mtpfs command then it's possible to access it.

The following is logged when the phone is connected.

Jan 28 21:33:57 juno kernel: usb 1-1.4: new high-speed USB device number 15 using ehci-pci
Jan 28 21:33:57 juno kernel: usb 1-1.4: New USB device found, idVendor=2931, idProduct=0a01
Jan 28 21:33:57 juno kernel: usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 28 21:33:57 juno kernel: usb 1-1.4: Product: Sailfish
Jan 28 21:33:57 juno kernel: usb 1-1.4: Manufacturer: Jolla
Jan 28 21:33:57 juno kernel: usb 1-1.4: SerialNumber: xxx
Jan 28 21:33:57 juno mtp-probe[29970]: checking bus 1, device 15: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4"
Jan 28 21:33:57 juno mtp-probe[29970]: bus: 1, device: 15 was not an MTP device
Jan 28 21:33:57 juno colord[1610]: Device added: sysfs-Jolla-Sailfish
Jan 28 21:33:57 juno gnome-session[1788]: (gnome-shell:1936): GLib-GIO-WARNING **: Dropping signal ReceivedChatMsg of type (issiu) since the type from the expected interface is (iiiiu)
Jan 28 21:33:58 juno gnome-session[1788]: (gnome-shell:1936): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: (gnome-shell:1936): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: (gnome-shell:1936): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: (gnome-shell:1936): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: Window manager warning: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
Jan 28 21:33:58 juno gnome-session[1788]: (tracker-miner-fs:2072): Tracker-WARNING **: Could not find parent node for URI:'gphoto2://[usb:001,015]/'
Jan 28 21:33:58 juno gnome-session[1788]: (tracker-miner-fs:2072): Tracker-WARNING **: NOTE: URI themes other than 'file://' are not supported currently.
Jan 28 21:33:58 juno gnome-session[1788]: (tracker-miner-fs:2072): Tracker-WARNING **: Could not find parent node for URI:'gphoto2://[usb:001,015]/'
Jan 28 21:33:58 juno gnome-session[1788]: (tracker-miner-fs:2072): Tracker-WARNING **: NOTE: URI themes other than 'file://' are not supported currently.

Comment 1 cetlorev 2014-02-05 19:23:54 UTC
Any chance that any thing will be done with this issue?

Comment 2 Fedora Update System 2014-08-30 19:16:31 UTC
libmtp-1.1.8-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libmtp-1.1.8-1.fc21

Comment 3 Fedora Update System 2014-09-01 19:45:15 UTC
Package libmtp-1.1.8-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmtp-1.1.8-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9984/libmtp-1.1.8-1.fc21
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-09-23 05:04:00 UTC
libmtp-1.1.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 nas 2015-04-07 19:15:13 UTC
Hello,

I too still have problems connecting my Jolla phone on my Fedora 21.

libmtp-1.1.8-1.fc21.x86_64

Linux localhost.localdomain 3.19.1-201.fc21.x86_64 #1 SMP Wed Mar 18 04:29:24 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Some days ago, I was connecting Jolla on laptop and after 1 - 2 minutes phone files and SD card were appearing.

Some days now, when I plug my Jolla on laptop, Sailfish device appears in "My Computer" but it is empty.

Please let me know if you need any debugging informations and how I could produce them, thanks


Note You need to log in before you can comment on or make changes to this bug.