Bug 105897 - kterm doesn't support UTF-8 locale
Summary: kterm doesn't support UTF-8 locale
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: kterm (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-29 07:13 UTC by TOYAMA Shin-ichi
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 07:46:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description TOYAMA Shin-ichi 2003-09-29 07:13:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
I can't input Japanese character correctly into command line on kterm.
gnome-terminal has no problem


Version-Release number of selected component (if applicable):
kterm-6.2.0-37, kinput2 version 3.1 (2002/10/03), XFree86-4.3.0-33

How reproducible:
Always

Steps to Reproduce:
1. open kterm with -xim option
2. type commands including japanese as follows.

echo<Space><Shift+Space>nihongo<Space><Enter><Enter><Shift+Space>ls<Enter>

3. wrong character will be displayed
4. And the first character of next command ( 'l' of 'ls' ) will be ignored.

bash: s: command not found


Expected Results:  Japanese character 'nihongo' will be displayed correctly.


Additional info:

Comment 1 Akira TAGOH 2003-10-21 11:55:46 UTC
because of kterm doesn't support UTF-8.

Comment 2 Akira TAGOH 2004-04-13 07:46:27 UTC
I'm closing this bug because we are going to support just one terminal
and we have decided to drop kterm from FC. If you found a bug on our
supported terminal(currently gnome-terminal), please feel free to file
a bug.


Note You need to log in before you can comment on or make changes to this bug.