An upstream commit  to the Passenger rubygem indicated that versions 4.0.5 and later are affected by a temporary file flaw described as follows:
Phusion Passenger creates a "server instance directory" in /tmp during startup,
which is a temporary directory that Phusion Passenger uses to store working files.
This directory is deleted after Phusion Passenger exits. For various technical
reasons, this directory must have a semi-predictable filename. If a local attacker
can predict this filename, and precreates a symlink with the same filename that
points to an arbitrary directory with mode 755, owner root and group root, then
the attacker will succeed in making Phusion Passenger write files and create
subdirectories inside that target directory. The following files/subdirectories
* generation-X, where X is a number.
If you happen to have a file inside the target directory called `control_process.pid`, then that file's contents are overwritten.
These files and directories are deleted during Phusion Passenger exit. The target
directory itself is not deleted, nor are any other contents inside the target
directory, although the symlink is.
It is fixed in upstream version 4.0.33.
Created rubygem-passenger tracking bugs for this issue:
Affects: fedora-20 [bug 1058993]
This fix is also required:
MITRE has assigned two CVEs here:
Use CVE-2014-1831 for the vulnerability with the "before 4.0.33"
Use CVE-2014-1832 for the vulnerability with the "4.0.33 and earlier"
CVE-2014-1831 would correspond to the original commit. This second commit would correspond to CVE-2014-1832 because "there's a race condition between the stat check introduced in 34b1087870c2" .
So both CVEs are applicable here, so noting them both.
(In reply to Vincent Danen from comment #0)
> It is fixed in upstream version 4.0.33.
>  https://github.com/phusion/passenger/commit/34b1087870c2
This should say 4.0.37, and hence:
(In reply to Vincent Danen from comment #3)
> Use CVE-2014-1831 for the vulnerability with the "before 4.0.33"
> affected versions.
> Use CVE-2014-1832 for the vulnerability with the "4.0.33 and earlier"
> affected versions.
should say "before 4.0.37" and "4.0.37 and earlier".