Bug 105904 - grub splashimage fails to load and text is garbled with nonstandard lcd (1440x900)
grub splashimage fails to load and text is garbled with nonstandard lcd (1440...
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-29 07:02 EDT by Phillip Davis
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 16:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phillip Davis 2003-09-29 07:02:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030807 Galeon/1.3.5

Description of problem:
grub, with a fresh install on a Toshiba P25-S507 laptop is illegible.  I know
grub well enough to know that I can make it boot fine, the underlying
functionality is fine, but the splashimage mode is trashed.  The display is a
1440x900 resolution instead of the more standardized 640x480 aspect ratio. 
There seems to be no method of selecting a nonstandard aspect ratio.  I turn off
the splashimage in the grub.conf and the text is totally fine.  The actual
background splashimage looks fine when it is displayed, but the text becomes a
mass of dots.  no real closeness to any text at all.  

Version-Release number of selected component (if applicable):
grub-0.93-4

How reproducible:
Always

Steps to Reproduce:
1. Install RH 9 on this particular type of monitor/resolution
2. boot machine
3. grub works, but is illegible
    

Actual Results:  Grub is illegible

Expected Results:  The text should be readable

Additional info:
Comment 1 Jeremy Katz 2003-09-29 16:19:58 EDT
grub is always 640x480, 16 color image.  There is nothing that can be done if
your  video chipset doesn't properly support this mode other than disabling of
the splashimage (which can't be done in an automated fashion as it's not really
something that can be probed)

Note You need to log in before you can comment on or make changes to this bug.