Bug 105907 - /sbin/setsysfont SYSONTACM vs SYSFONTACM
/sbin/setsysfont SYSONTACM vs SYSFONTACM
Status: CLOSED DUPLICATE of bug 105035
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-29 09:07 EDT by David Johnston
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Johnston 2003-09-29 09:07:37 EDT
Description of problem:
Line 31 of /sbin/setsysfont reads as follows:
    if [ ! -f /lib/kbd/consoletrans/$SYSONTACM_to_uni.trans ]; then

It should read as follows:
    if [ ! -f /lib/kbd/consoletrans/$SYSFONTACM_to_uni.trans ]; then

This forces SYSFONTACM to be set to `echo $SYSFONTACM | sed "s|iso0|8859-|g"`
regardless of whether or not *iso0*_to_uni.trans exists.

Line 31 is the only reference to SYSONTACM, there are 6 other references to
SYSFONTACM; looks like a typo to me.

Version-Release number of selected component (if applicable):
initscripts-7.14-1
Comment 1 Bill Nottingham 2003-09-29 17:20:39 EDT

*** This bug has been marked as a duplicate of 105035 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.