Bug 105929 - samba 3 shares : no browsing from win-box
samba 3 shares : no browsing from win-box
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-29 12:10 EDT by Rainer Hattenhauer
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-01 16:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smb.conf (10.45 KB, text/plain)
2003-09-29 12:12 EDT, Rainer Hattenhauer
no flags Details

  None (edit)
Description Rainer Hattenhauer 2003-09-29 12:10:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
From windows box, you can "see" the fedora samba 3 server, but you can't access
or browse shares even in security=share mode.

See attachement of smb.conf, I used the same smb.conf as for samba v2 which
worked with RH9.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.edit workgroup and server string in smb.conf
2.edit security=share in smb.conf
3./etc/init.d/smb restart
    

Actual Results:  See the samba share in the network environment of the windoze
box, but trying to use it (by simple clicking) yields. Message (translation from
german, maybe bad):

You cannot access to the computer. Probably you have no rights to use this
network ressource.



Expected Results:  Browse the linux / samba box

Additional info:

Probably a configuration issue of the new samba v3. Some additional
configuration of the default smb.conf should be done to give unexperienced users
(like me ;-)) a simple startup.

Configuration using redhat-config-samba doesn't work too, by the way. With RH 9,
it went straightforward.
Comment 1 Rainer Hattenhauer 2003-09-29 12:12:45 EDT
Created attachment 94823 [details]
smb.conf

My smb.conf
Comment 2 David Lawrence 2003-09-29 15:15:37 EDT
Does this still happen if you run "service iptables stop" as root and then try
to browse the shares?
Comment 3 Rainer Hattenhauer 2003-09-29 15:40:23 EDT
No, you're right:

when I run /sbin/service iptables stop, I'm able to browse the defined share. 
I only cannot access to the share (same access restriction message), but that 
might be due to my configuration (I should create a smb-user to access the 
shrare). I will tell you tomorrow if I had success.
Comment 4 David Lawrence 2003-09-29 15:51:30 EDT
Ok, please remember to close this report then if it works out.
Comment 5 David Lawrence 2003-10-01 16:39:15 EDT
Comment from Rainer Hattenhauer:

O.k. now everything works fine except the redhat-config-samba tool. It doesn't
produce proper smb.conf files, perhaps a little more work on this field is needed.
I've been edited the file by hand without using the redhat-config-samba tool,
and had been able to work with a share even in security=user mode (smbpasswd
needed).

And you have to set up your firewall properly to get access to the samba share,
workaround: /sbin/service iptables stop for testing purposes of samba.

Thanks for help
                  Rainer

Note You need to log in before you can comment on or make changes to this bug.