Bug 1059461 - Re add and fix make check
Summary: Re add and fix make check
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-29 22:15 UTC by Orion Poplawski
Modified: 2014-09-09 22:23 UTC (History)
2 users (show)

Fixed In Version: rkward-0.6.1-9.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-06 20:30:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2014-01-29 22:15:50 UTC
Description of problem:

It would be good to run the test suite again via:

%check
make check

However, it is currently failing.  For e.g. on F20 x86_64 I get:

running code in 'reg-S4.R' ... OK
  comparing 'reg-S4.Rout' to './reg-S4.Rout.save' ... OK
running code in 'reg-BLAS.R' ...make[3]: *** [reg-BLAS.Rout] Error 1
make[3]: Leaving directory `/export/home/orion/fedora/R/R-3.0.2/tests'
make[2]: *** [test-Reg] Error 2
make[2]: Leaving directory `/export/home/orion/fedora/R/R-3.0.2/tests'
make[1]: *** [test-all-basics] Error 1
make[1]: Leaving directory `/export/home/orion/fedora/R/R-3.0.2/tests'
make: *** [check] Error 2

Version-Release number of selected component (if applicable):
R-3.0.2-3.fc21

Comment 1 Orion Poplawski 2014-03-03 03:16:50 UTC
Upstream also indicates that using system tre library is causing a failure in regexp tests which we should verify.

Comment 2 Orion Poplawski 2014-03-03 04:25:08 UTC
BLAS failure seems to be:

> ## found from fallback test in slam 0.1-15
> ## most likely indicates an inaedquate BLAS.
> x <- matrix(c(1, 0, NA, 1), 2, 2)
> y <- matrix(c(1, 0, 0, 2, 1, 0), 3, 2)
> (z <- tcrossprod(x, y))
     [,1] [,2] [,3]
[1,]   NA   NA    0
[2,]    2    1    0
> stopifnot(identical(z, x %*% t(y)))
Error: identical(z, x %*% t(y)) is not TRUE
Execution halted

Odd thing is I cannot reproduce with the installed rpm, but I can with the build tree.

Comment 3 Orion Poplawski 2014-03-03 04:26:32 UTC
Correct I believe is:

> (z <- tcrossprod(x, y))
     [,1] [,2] [,3]
[1,]   NA   NA   NA
[2,]    2    1    0

Comment 4 Orion Poplawski 2014-03-04 00:17:27 UTC
This was broken with the addition of --with-blas to configure.

Comment 5 Fedora Update System 2014-07-17 14:50:45 UTC
rkward-0.6.1-9.fc20,rpy-2.3.10-2.fc20,R-3.1.1-1.fc20,R-qtl-1.32.10-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rkward-0.6.1-9.fc20,rpy-2.3.10-2.fc20,R-3.1.1-1.fc20,R-qtl-1.32.10-4.fc20

Comment 6 Fedora Update System 2014-07-17 14:50:58 UTC
rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19

Comment 7 Fedora Update System 2014-07-17 14:51:08 UTC
R-3.1.1-1.el5,R-qtl-1.32.10-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/R-3.1.1-1.el5,R-qtl-1.32.10-4.el5

Comment 8 Fedora Update System 2014-07-17 14:51:20 UTC
R-3.1.1-1.el6,R-qtl-1.32.10-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/R-3.1.1-1.el6,R-qtl-1.32.10-4.el6

Comment 9 Fedora Update System 2014-07-19 06:06:52 UTC
Package rkward-0.6.1-9.fc19, rpy-2.3.10-2.fc19, R-3.1.1-1.fc19, R-qtl-1.32.10-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rkward-0.6.1-9.fc19 rpy-2.3.10-2.fc19 R-3.1.1-1.fc19 R-qtl-1.32.10-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8532/rkward-0.6.1-9.fc19,rpy-2.3.10-2.fc19,R-3.1.1-1.fc19,R-qtl-1.32.10-4.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-09-06 20:30:30 UTC
R-3.1.1-1.el5, R-qtl-1.32.10-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-09-06 20:31:08 UTC
R-3.1.1-1.el6, R-qtl-1.32.10-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-09-09 22:08:28 UTC
rkward-0.6.1-9.fc19, rpy-2.3.10-2.fc19, R-3.1.1-1.fc19, R-qtl-1.32.10-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-09-09 22:23:36 UTC
rkward-0.6.1-9.fc20, rpy-2.3.10-2.fc20, R-3.1.1-1.fc20, R-qtl-1.32.10-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.