Bug 1059892 - OVIRT-PYTHON-SDK Cluster object lacks 'ksm' and 'ha_reservation' parameter that exists in api.xsd
Summary: OVIRT-PYTHON-SDK Cluster object lacks 'ksm' and 'ha_reservation' parameter th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-sdk
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Juan Hernández
QA Contact: Ilia Meerovich
URL:
Whiteboard: infra
: 1059125 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-01-30 20:44 UTC by Ilia Meerovich
Modified: 2016-07-05 00:06 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-sdk-python-3.4.0.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:31:19 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24646 0 None None None Never

Description Ilia Meerovich 2014-01-30 20:44:24 UTC
rpms:
ovirt-engine-3.4.0-0.5.beta1.el6.noarch
ovirt-engine-sdk-python-3.4.0.2-1.20140114.gitbaccf38.el6

Appears in api.xsd:

<xs:element ref="ksm" minOccurs="0" maxOccurs="1"/>
<xs:element name="ha_reservation" type="xs:boolean" minOccurs="0" maxOccurs="1"/>

doesn't appear in python sdk (and most probably doesn't appear in java sdk too)

Comment 1 Juan Hernández 2014-01-30 21:37:25 UTC
These properties have been added after the latest refresh of the SDKs. They will be available in the next release.

Comment 2 Ilia Meerovich 2014-02-17 08:20:49 UTC
raising severity to urgent since it is tier 0 bug

Comment 3 Juan Hernández 2014-02-18 13:53:08 UTC
The packages containing the fix for this issue are available here:

http://jhernand.fedorapeople.org/rpms/ovirt-engine-sdk-python/3.4.0.4-1

Comment 4 Juan Hernández 2014-02-18 15:41:39 UTC
*** Bug 1059125 has been marked as a duplicate of this bug. ***

Comment 5 Ilia Meerovich 2014-02-19 08:49:12 UTC
imeerovi@imeerovi ~/git/ART (RHEVM-979-dc-search) $ bpython
>>> from ovirtsdk.xml import params
>>> 
>>> from ovirtsdk.api import API 
>>> api = API(url='https://ilia-rhevm.qa.lab.tlv.redhat.com:443', username='admin@internal', password='123456', insecure=True) 
>>> d = api.datacenters.add(params.DataCenter(name='dc_iscsi34', storage_type='iscsi', version=params.Version(major='3', minor='4')))
>>> api.clusters.add(params.Cluster(name='cl_iscsi34', cpu=params.CPU(id='Intel Conroe Family'), data_center=d, ha_reservation=True))
<ovirtsdk.infrastructure.brokers.Cluster object at 0x2d320d0>
>>> cl = api.clusters.list()[0]
>>> cl.get_ksm()
<ovirtsdk.xml.params.KSM object at 0x2fce110>
>>> 
imeerovi@imeerovi ~/git/ART (RHEVM-979-dc-search) $ rpm -q ovirt-engine-sdk-python
ovirt-engine-sdk-python-3.4.0.4-1.el6.noarch

Comment 6 Sandro Bonazzola 2014-03-31 12:31:19 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.