Bug 10600 - spec file needs a correction
spec file needs a correction
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-05 14:15 EDT by michal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 16:25:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed archive with modified util-linux specs and extra patches (8.07 KB, application/octet-stream)
2001-02-06 14:24 EST, Michal Jaegermann
no flags Details

  None (edit)
Description michal 2000-04-05 14:15:41 EDT
Spec file for util-linux 2.10f says 'make "RPM_OPT_FLAGS=$RPM_OPT_FLAGS"'
which is not doing to well if one would need to pass some other flags
here.  It should read 'make "OPT==$RPM_OPT_FLAGS"' for a desired effect.

On the top of it 'fdisk' throws multum of "unaligned access" on alpha.

If somebody would want a reworked source rpm file for 2.10h, with
much better working fdisk for disklabels on alpha, then tell me where
to upload that.  I am not going to attach it to this message.

  Michal Jaegermann,
  michal@harddata.com
Comment 1 Jeff Johnson 2000-05-14 14:33:59 EDT
Could you attach a patch and/or spec file to this message? Thanks.
Comment 2 Michal Jaegermann 2001-02-06 14:23:24 EST
Attached is a spec file in question and two extra patches, Alpha specific,
referenced in it.  Please note dates. :-)

  Michal
Comment 3 Michal Jaegermann 2001-02-06 14:24:54 EST
Created attachment 9161 [details]
compressed archive with modified util-linux specs and extra patches
Comment 4 Erik Troan 2001-02-06 16:25:04 EST
OPT change in 2.10p-6, the fdisk ones look out of date now. Please tell me if
patches are still needed.
Comment 5 Michal Jaegermann 2001-02-06 17:24:12 EST
> OPT change in 2.10p-6, the fdisk ones look out of date now.

No, I do not see it.  Look at a file MCONFIG in a top directory of
util-linux.  Even patched with "redhat" changes it is still using
"OPT" to add other options.  There is really no good way to pass
automatically such platform dependendent flags like '-mcpu=ev4 -Wa,-mev45'
from ~/.rpmrc, or whatever else you may want there, other than with
a proposed change.

Also of alpha specific patches one about warning seems to be indeed
obsolete (my name shows up in a header comment of fdisk.c :-) but the
other one is still pretty vital for Alpha if "not official" and it
does change an fdisk behaviour in this particular case.  Also 'bdsfdisk'
for scripted writes of disklabels (Jeff, i.e. jbj, got that one from me
a while ago) depends on this.  Mind you, this is not tested; just a quick
peek at the current code.
Comment 6 Erik Troan 2001-02-06 17:27:44 EST
I haven't built the new util-linux yet, I will tonight. If it needs any more
patches when you see it, reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.