This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 106004 - Broadcom tg3 driver duplex won't set
Broadcom tg3 driver duplex won't set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Miller
Brian Brock
Dell views this as critical bug for U...
:
: 108115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-01 17:47 EDT by matt poepping
Modified: 2007-11-30 17:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 11:00:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix for ETHTOOL_SSET bug in tg3 driver. (1.11 KB, patch)
2003-11-05 17:42 EST, David Miller
no flags Details | Diff

  None (edit)
Description matt poepping 2003-10-01 17:47:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827

Description of problem:
Using ethtool, I can not get the broadcom card to set to full duplex. The
command i'm using (which works for me on the other machines) is "ethtool -s eth0
duplex full speed 100 autoneg off"



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot 
2. ethtool -s eth0 duplex full speed 100 autoneg off
3. nothing happens
    

Actual Results:  duplex stayed the same

Expected Results:  duplex switch to full 

Additional info:

Linux ln3012 2.4.21-3.ELsmp #1 SMP Fri Sep 19 14:06:12 EDT 2003 i686 i686 i386
GNU/Linux

 modinfo tg3
filename:    /lib/modules/2.4.21-3.ELsmp/kernel/drivers/net/tg3.o
description: "Broadcom Tigon3 ethernet driver"
author:      "David S. Miller (davem@redhat.com) and Jeff Garzik
(jgarzik@pobox.com)"
license:     "GPL"
parm:        tg3_debug int, description "Tigon3 bitmapped debugging message
enable value"
Comment 1 matt poepping 2003-10-01 18:45:33 EDT
I rebooted it a few more times with no luck, tried differnt options on ethtool,
then tried 

ethtool -s eth0 autoneg off
wait a second
ethtool -s eth0 duplex full

and it came up. I'm not sure if it came up because I did it like that, or if I
just got lucky.  I have it up and running so the developers can continue to test
on it, but I still think its broken.

Thanks,
matt
Comment 2 matt poepping 2003-10-02 15:23:59 EDT
On that last comment, it booted to the older test kernel, so it seems that the
older one works, but the new kernel doesn't. I just rebooted to the newest test
kernel, and just turning autoneg off, causes me to loose link.

thanks,
Matt
Comment 3 acount closed by user 2003-10-02 19:33:31 EDT
what is tg3 version? 
show us # ethtool  -i eth0 and # ethtool eth0

I know that  Jeff G. doesn't like that people turn off autoneg. Maybe with this
driver release it cannot be disabled
Comment 4 matt poepping 2003-10-03 11:58:01 EDT
I've also tried ethtool without using autoneg off, but it won't set the card to
full duplex.


ethtool -i eth0
driver: tg3
version: 2.2
firmware-version: 
bus-info: 02:01.0


Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes
Comment 6 Larry Troan 2003-11-04 12:36:23 EST
Amit from Dell has been able to reproduce this bug. It needs to be
fixed in the next errata.
Comment 8 Larry Troan 2003-11-04 16:40:02 EST
Issue Tracker 29166 opened as sev 2.
Comment 9 Michael K. Johnson 2003-11-05 10:16:28 EST
Jeff points out that this could have happened because of a change in
ethtool as well as tg3 -- can we check latest ethtool from
http://sf.net/projects/gkernel/ as well as earlier ethtool, perhaps
from RHL9?
Comment 11 Dave Maley 2003-11-05 12:56:18 EST
tested ethtool from RHL9 (1.6-5) and the latest from
http://sf.net/projects/gkernel/ (1.8) -> neither worked

- looks like this is a tg3 issue
Comment 12 Dave Maley 2003-11-05 14:33:08 EST
just dropped a RHL9 kernel (2.4.20-20.9) on this system and ethtool
starting working properly ...
Comment 13 David Miller 2003-11-05 17:42:20 EST
Created attachment 95742 [details]
Fix for ETHTOOL_SSET bug in tg3 driver.
Comment 14 David Miller 2003-11-05 17:43:42 EST
The attached patch should fix the bug, problems were added to
ETHTOOL_SSET handling during the conversion of the tg3 driver
over to ethtool_ops.
Comment 15 Larry Troan 2003-12-09 09:33:00 EST
FROM ISSUE TRACKER....
Event posted 11-06-2003 03:30pm by Bhutani with duration of 0.00     
  First things first - Patch works great!

I am assuming that this fix will be in QU1. I know Red Hat was working
on a "DKMS like" device driver update model. Are there any updates on
that? In the absence of such a mechanism and considering that this is
a critical enough bug to be a high volume call generator, Dell will
have to update this driver in the factory using DKMS.    Event posted
11-11-2003 11:13am by ltroan with duration of 0.30 I've appended your
last paragraph to Issue Tracker 28574 and requested comments on our
support for DKMS.

Bhutani assigned to issue for Dell-Engineering.
Status set to: Fix Pending    

------------------------------------------
Event posted 11-18-2003 12:51pm by Bhutani with duration of 0.00
tg3-2.2-1dkms.noarch.rpm
Attaching the DKMS version of tg3 v2.2 driver that will be installed
with Taroon in Factory and DSA. FYI, you will need the latest version
of DKMS from www.lerhaupt.com/dkms before you can install this RPM.

File uploaded: tg3-2.2-1dkms.noarch.rpm    

--------------------------------------------------
Event posted 11-26-2003 03:26pm by Bhutani with duration of 0.00
tg3-2.2-3dkms.noarch.rpm
Updated version of the tg3 DKMS package that will be Factory installed
for Taroon on all platforms attached. As before you will need the
latest version of DKMS from www.lerhaupt.com/dkms before you can
install this RPM.

File uploaded: tg3-2.2-3dkms.noarch.rpm
Comment 19 Ingvar Hagelund 2004-03-04 03:41:19 EST
It seems that (1) this bug actually is resolved, as marked in
RHSA-2004-017, and that (2) bug #108115 is a duplicate of this bug. Am
I wrong or am I right?

Ingvar
Comment 20 Amit Bhutani 2004-03-04 11:00:49 EST
Fixed in RHEL 3 U1.
Comment 21 Ernie Petrides 2004-12-02 20:54:32 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2004-017.html
Comment 22 Ernie Petrides 2005-10-05 22:16:16 EDT
*** Bug 108115 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.