Bug 106006 - RFE: Display network card make/model during network config
RFE: Display network card make/model during network config
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-01 17:59 EDT by Richard Lloyd
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-01 21:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2003-10-01 17:59:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
When I am configuring the multiple network cards of a machine during
Fedora OS installation (inside Anaconda), I have no idea which card is
"eth0", which is "eth1" and so on. Displaying the make and model of the
network cards in the network config section when they are selected would
help enormously. Something like the appropriate "Ethernet controller"
lines as seen by the output of "lspci" would be good enough.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do a Fedora OS installation and get to the network configuration screen in
Anaconda.
    

Actual Results:  You are presented with a screen listing the Ethernet cards
installed (which can then be clicked on and configured for IP, netmask etc.). If
you have multiple network cards installed (which are often different brands -
certainly happens with Dell Poweredge servers), you cannot distinguish between
the multiple cards in terms of make or model.

Expected Results:  On a multi-network card machine where you wish to enable two
(or more) cards on your network, you will inevitably want to know which one is
which (so you can wire it to the correct network switch) - this is particularly
true of dual-carded proxy servers, where one card is on a corporate private
intranet and the other is on the "live" internet.
Hence, you need a way to distinguish "eth0" from "eth1" so that you wire the
right port on the machine to the correct switch - I suggest the make/model of
the card may be good enough, but if there's other unique info, then put that in
too (because the two cards may be the same make/model of course).

Additional info:

The number of times I get caught by this on Dell Poweredge servers (which one's
the "onboard LAN" and which is the extra Gigabit card we ordered with it ?) is
getting somewhat out of hand :-)
Comment 1 Jeremy Katz 2003-10-01 21:14:16 EDT
Click to edit the interface and then you get the make/model.  Shoving it into
the TreeView makes things too large to be useful.

Note You need to log in before you can comment on or make changes to this bug.