Bug 10602 - There's documentation in there that's not in /usr/doc
Summary: There's documentation in there that's not in /usr/doc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: stylesheets   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-05 18:25 UTC by kop
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-05 18:25:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kop 2000-04-05 18:25:44 UTC
usr/lib/sgml/stylesheets/nwalsh-modular/doc/ contains some really useful
documentation, but it's hard (as in "wack your head against the wall for a
while") to find because it's not in /usr/doc.

I'd probably be a good idea to put the doc in an nwalsh-modular
sub-directory, to make it more clear that it just applies to the
nwalsh-modular style sheets.

(Hate to do this to your bug tracking system)  Also...

/usr/lib/sgml/stylesheets/dbtohtml.dsl dosen't work (for me anyhow, with
jade), although it looks like a good example and should probably be kept
around.  (I think it needs additional <> markup above and below the scheme
code, sorta like this:

----------<snip>-----------

4.4. Customizing the Stylesheets

The best way to customize the stylesheets is to write your own "driver"
file; this is a stylesheet that contains your local modifications and then
includes the
appropriate stylesheet from the standard distribution by reference. This
allows you to make local changes and extensions without modifying the
distributed files,
which makes upgrading to the next release much simpler.

4.4.1. Writing Your Own Driver

A basic driver file looks like this:

<!DOCTYPE style-sheet PUBLIC "-//James Clark//DTD DSSSL Style Sheet//EN" [
<!ENTITY dbstyle PUBLIC "-//Norman Walsh//DOCUMENT DocBook Print
Stylesheet//EN" CDATA DSSSL>
]>

<style-sheet>
<style-specification use="docbook">
<style-specification-body>

;; your changes go here...

</style-specification-body>
</style-specification>
<external-specification id="docbook" document="dbstyle">
</style-sheet>

----------<snip>-----------

but idunnknow.  Maybe changing it to work with jade would completely break
something else.)

Comment 1 Bill Nottingham 2000-06-10 22:12:57 UTC
Fixed in stylesheets-1.54.13rh-2, which should be
in the next rawhide release - thanks for the bug
report!


Note You need to log in before you can comment on or make changes to this bug.