Bug 106022 - GeForce 4 Ti 4400 X server crashes when firstboot is run
GeForce 4 Ti 4400 X server crashes when firstboot is run
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: XFree86 (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-01 20:33 EDT by Marc J. Miller
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 21:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log (35.66 KB, text/plain)
2003-10-01 20:35 EDT, Marc J. Miller
no flags Details
XF86Config (after install) (3.36 KB, text/plain)
2003-10-01 20:36 EDT, Marc J. Miller
no flags Details
/var/log/messages (25.42 KB, text/plain)
2003-10-01 20:36 EDT, Marc J. Miller
no flags Details
XF86Config (after reconfiguring; tested, works) (3.41 KB, text/plain)
2003-10-02 15:01 EDT, Marc J. Miller
no flags Details

  None (edit)
Description Marc J. Miller 2003-10-01 20:33:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:
After installing "Everything" for RHEL3 AS for AMD64 on an AMD Solo, when
firstboot is run, X fails to start (screen goes black a few times).  Logs and
the X config file are enclosed.  firstboot recognizes the problem and tries to
start the X configuration utility, which also fails to start (screen goes black
a few times).

lspci calls video card a "Nvidia NV25 GeForce 4 Ti 4400"

Running "redhat-config-xfree86 --reconfig" and choosing the same settings seems
fixes this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Boot from RHEL3 AS for AMD64 CD1
2.  Choose to format existing partitions rather than creating new ones
3.  Install everything
4.  Remove media for reboot when prompted.

    

Actual Results:  Just after it tries to run "firstboot" screen will go black
about 3 times, and then user will be told that X failed to start.

Expected Results:  User should be prompted to create user accounts (in graphical
mode)

Additional info:

Log files will be attached.
Comment 1 Marc J. Miller 2003-10-01 20:35:39 EDT
Created attachment 94858 [details]
XFree86.0.log
Comment 2 Marc J. Miller 2003-10-01 20:36:21 EDT
Created attachment 94859 [details]
XF86Config (after install)
Comment 3 Marc J. Miller 2003-10-01 20:36:55 EDT
Created attachment 94860 [details]
/var/log/messages
Comment 4 Marc J. Miller 2003-10-01 20:38:49 EDT
Not "Q3 beta"... this is RC1.
Comment 5 Marc J. Miller 2003-10-01 20:42:13 EDT
Bug in bugzilla -- I had selected multiple applicable components, as at various
times the problem seemed to be in one or another:  gdm, (firstboot -- not
selectable), and XFree.  This seems to be more of an XFree problem than anything
else.
Comment 6 Mike A. Harris 2003-10-01 21:24:55 EDT
Marc, can you also attach the config file that was generated at install time
for your particular card, so I can compare the two?  I don't have that particular
video board or I'd do a test install myself.

I have a feeling this is a bug in anaconda.
Comment 7 Marc J. Miller 2003-10-02 15:01:10 EDT
Created attachment 94892 [details]
XF86Config (after reconfiguring; tested, works)

This is the XF86Config produced from running "redhat-config-xfree86 --reconfig"
Comment 8 Brent Fox 2004-07-20 11:29:19 EDT
Marc, are you still seeing this problem?  If so, what we need is the
XF86Config file before you reconfigure it with redhat-config-xfree86.
 Then we can try to see if anaconda is creating a broken XF86Config
file or not.
Comment 9 Marc J. Miller 2004-10-05 21:28:18 EDT
Seems to be okay as of Update 2.  This bugzilla can be closed.

Note You need to log in before you can comment on or make changes to this bug.