Bug 1060355 - [GSS] (6.3.0) Schema validation + multiple schema imports in same namespace + catalog lookup doesn't work
[GSS] (6.3.0) Schema validation + multiple schema imports in same namespace +...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.2.1
Unspecified Unspecified
unspecified Severity unspecified
: DR0
: EAP 6.3.0
Assigned To: Alessio Soldano
Rostislav Svoboda
Russell Dickenson
:
Depends On:
Blocks: 1040731
  Show dependency treegraph
 
Reported: 2014-01-31 17:07 EST by Kyle Lape
Modified: 2014-06-28 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An issue that caused the algorithm in `org.apache.cxf.wsdl.EndpointReferenceUtils.SchemaLSResourceResolver#resolveResource` to not resolve the correct schema and return only the first schema it found has been corrected with an upgrade to the CXF component.
Story Points: ---
Clone Of:
: 1062691 (view as bug list)
Environment:
Last Closed: 2014-06-28 11:37:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA CXF-5532 None None None Never

  None (edit)
Description Kyle Lape 2014-01-31 17:07:18 EST
Catalog lookup is enabled to prevent requests to third party servers, and the third party schema referenced in the WSDL references multiple schemas in the same namespace.

When schema validation is enabled, the algorithm in org.apache.cxf.wsdl.EndpointReferenceUtils.SchemaLSResourceResolver#resolveResource does not resolve the correct schema since in the above scenario it falls back to namespace-only resolution, which returns the first schema it sees.  This can be fixed by trying to resolve on only the "filename" before resorting to namespace-only resolution.
Comment 2 Kabir Khan 2014-04-04 10:57:20 EDT
Setting to ON_QA since upgrade should fix this
Comment 3 Petr Sakař 2014-04-08 09:27:08 EDT
Verified with verifier from BZ1062691 for EAP-6.3.0.ER1

Note You need to log in before you can comment on or make changes to this bug.