Bug 1060528 - Error response to DELETE request of 'Everyone' group doesn't contains 'detail' field
Summary: Error response to DELETE request of 'Everyone' group doesn't contains 'detail...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Eli Mesika
QA Contact: Ilia Meerovich
URL:
Whiteboard: infra
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-02 11:28 UTC by Ilia Meerovich
Modified: 2016-07-05 00:06 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:32:47 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24569 0 None MERGED core:NPE when attempting to delete Everyone... Never
oVirt gerrit 24952 0 None MERGED core:NPE when attempting to delete Everyone... Never

Description Ilia Meerovich 2014-02-02 11:28:10 UTC
DELETE request of 'Everyone' group:
https://ilia-rhevm.qa.lab.tlv.redhat.com:443/api/groups/eee00000-0000-0000-0000-123456789eee

Should fail with 500 error and return message that contains 'detail' field.
it is regression from previous release
In previous ovirt release
ovirt-engine-3.4.0-0.2.master.20140112020439.git9ad8529.el:

2014-01-26 21:50:04,830 - MainThread - users - DEBUG - DELETE request content is --  url:/api/groups/eee00000-0000-0000-0000-123456789eee
2014-01-26 21:50:04,923 - MainThread - core_api - DEBUG - Request DELETE response time: 0.030
2014-01-26 21:50:04,923 - MainThread - users - DEBUG - Response body for DELETE request is: <fault><reason>Operation Failed</reason><detail>[Cannot remove the built-in group &quot;Everyone&quot;.]</detail></fault> 

In current release ovirt-engine-3.4.0-0.5.beta1.el6:
2014-02-01 21:50:38,889 - MainThread - users - DEBUG - DELETE request content is --  url:/api/groups/eee00000-0000-0000-0000-123456789eee
2014-02-01 21:50:39,192 - MainThread - core_api - DEBUG - Request DELETE response time: 0.050
2014-02-01 21:50:39,192 - MainThread - users - DEBUG - Response body for DELETE request is: <fault><reason>Operation Failed</reason></fault>

Comment 1 Ilia Meerovich 2014-02-17 08:19:47 UTC
raising severity to urgent since it is tier 0 bug

Comment 2 Eli Mesika 2014-02-17 08:29:10 UTC
Please specify why do you think this is urgent ?
Your explanation in comment 1 is not clear

Comment 3 Ilia Meerovich 2014-02-17 08:43:15 UTC
CI and QE are running regression_mixed test that is basic api sanity test.
If this test fails - it is zero level bug from QE point. this test checks a lot of stuff. one of thins that it checks is if error response for various error codes (mostly 40x and 50x) is correct. in this case it is not that's why it is zero level bug for both CI and QE.

Comment 4 Sandro Bonazzola 2014-02-24 08:18:02 UTC
This bug is blocking 3.4.0 final release. ETA for fixing it?

Comment 5 Eli Mesika 2014-02-24 11:16:54 UTC
I hope that today , waiting for review

Comment 6 Sandro Bonazzola 2014-03-03 14:40:32 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 7 Ilia Meerovich 2014-03-04 15:17:21 UTC
verified with downstream build rhevm-3.4.0-0.3

Comment 8 Sandro Bonazzola 2014-03-31 12:32:47 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.