Bug 1060627 - [Regression] Drop down navmenu does not work in the editor [NEEDINFO]
Summary: [Regression] Drop down navmenu does not work in the editor
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: development
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.3
Assignee: Alex Eng
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-03 05:29 UTC by Damian Jansen
Modified: 2014-03-20 05:47 UTC (History)
3 users (show)

Fixed In Version: 3.3.0-SNAPSHOT (20140212-1531)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 05:47:26 UTC
lbrooker: needinfo? (camunoz)


Attachments (Terms of Use)

Description Damian Jansen 2014-02-03 05:29:51 UTC
Description of problem:
The drop down menu does not work when using the editor. Clicking it seems to take the user to the same url with "#nav-user" appended to it

Version-Release number of selected component (if applicable):
3.3.0 RC1

How reproducible:
Easy always

Steps to Reproduce:
1. Sign in as admin, click Projects
2. Click a project, then a version, then a language
3. Click the dropdown menu (top right) when the editor/doc list has loaded

Actual results:
Nothing

Expected results:
Drop down menu drops down

Additional info:

Comment 1 Carlos Munoz 2014-02-05 23:32:27 UTC
Luke, could you take a look at this? This might have something to do with css, similar to what we're seeing with some other components not showing up.

Comment 2 Luke Brooker 2014-02-06 03:35:44 UTC
(In reply to Carlos Munoz from comment #1)
This is purely to do with the order of script files in the main template. Alex updated it for the jsf pages but mustn't have for the editor template. Do you want me to change that?

> Luke, could you take a look at this? This might have something to do with
> css, similar to what we're seeing with some other components not showing up.

Comment 3 Alex Eng 2014-02-09 23:09:31 UTC
Pull request: https://github.com/zanata/zanata-server/pull/360

Comment 4 Alex Eng 2014-02-10 01:40:34 UTC
Pull request: https://github.com/zanata/zanata-server/pull/362

Comment 5 Damian Jansen 2014-02-12 05:40:31 UTC
Verified at 29de4991b655f8742b35b78d2508da6d8119f41d

Comment 6 Sean Flanigan 2014-03-20 05:47:26 UTC
Closing VERIFIED bugs for Zanata server 3.3.2.


Note You need to log in before you can comment on or make changes to this bug.