Bug 1060633 - a2ps: insecure temporary file use [epel-6]
Summary: a2ps: insecure temporary file use [epel-6]
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: a2ps
Version: el6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mark Chappell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: CVE-2001-1593
TreeView+ depends on / blocked
 
Reported: 2014-02-03 06:27 UTC by Murray McAllister
Modified: 2015-01-04 22:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-03 15:43:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Murray McAllister 2014-02-03 06:27:23 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora EPEL.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, please use the bodhi submission link
noted in the next comment(s).  This will include the bug IDs of this
tracking bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

epel-6 tracking bug for a2ps: see blocks bug list for full details of the security issue(s).

[bug automatically created by: add-tracking-bugs]

Comment 1 Murray McAllister 2014-02-03 06:27:36 UTC
Please use the following update submission link to create the Bodhi
request for this issue as it contains the top-level parent bug(s) as well
as this tracking bug.  This will ensure that all associated bugs get
updated when new packages are pushed to stable.

Please also ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=1060630,1060633

Comment 2 Tim Waugh 2014-02-03 15:43:31 UTC
Not affected. This has been fixed since 2001 due to a2ps-4.13-security.patch being applied. This patch changes tempname_ensure() so that mkstemp() is used rather than tempnam().

It looks like this was the original patch:

* Fri Jan 05 2001 Preston Brown <pbrown>
- security patch for tmpfile creation from Olaf Kirch <okir>

followed the next month by a fix to that patch:

* Mon Feb 12 2001 Tim Waugh <twaugh>
- Fix tmpfile security patch so that it actually _works_ (bug #27155).


Note You need to log in before you can comment on or make changes to this bug.