Bug 1060984 - Remove Cherokee logo images
Remove Cherokee logo images
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cherokee (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-04 00:07 EST by Richard Fontana
Modified: 2014-08-25 20:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-13 21:34:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Fontana 2014-02-04 00:07:14 EST
To protect the Fedora trademark and goodwill, Red Hat requests removal of the following files from the cherokee package:
themes/default/logo.png
www/cherokee-logo.png
www/favicon.ico
admin/icons/cherokee-admin-launcher*
and any other such images. 

This bug is related to but not duplicative of bug # 681339. Unlike the earlier bug, this bug is filed in my capacity as counsel for Red Hat, Inc.
Comment 1 Richard Fontana 2014-02-04 00:09:44 EST
Adding Fedora Legal to cc.
Comment 2 Tom "spot" Callaway 2014-02-04 03:59:11 EST
Mo, would you be willing to create replacement art for the files mentioned in this bug? That would be the simplest solution.
Comment 3 Stefan de Konink 2014-02-04 11:50:45 EST
Based on the Human Rights Counsil "Report of the Special Rapporteur in the field of cultural rights, Farida Shaheed" [1] we, the Cherokee Webserver community would formally like to request:
 
 1) not to take any action on our creative works
 2) add defamation to employee personal file of Richard Fontana in based on the following reply: https://bugzilla.redhat.com/show_bug.cgi?id=681339#c56 It is clear, even the issue is given peace, we as community are not done with his personal crusade against our project and creative works


We are looking forward to your formal reply in case these matters.

[1] http://artsfreedom.org/wp-content/uploads/2013/04/A-HRC-23-34_en.pdf
Comment 4 Richard Fontana 2014-02-04 12:53:03 EST
The cited "Report of the Special Rapporteur in the field of cultural rights" is of no relevance to this matter whatsoever. Neither the Fedora Project nor Red Hat is a state. Neither Fedora or Red Hat have any responsibility or obligation to distribute any particular content, any more than the Cherokee project has some responsibility or obligation to distribute a logo of my own design. I believe I have made this point in the other bug.

I am unclear as to your definition of "defamation" given the cite to that comment. 

Nevertheless, your response indicates that the Cherokee project has now reached the point of making threats (however unclear) against individuals. It is for the latter reason that I believe we must now pull Cherokee out of Fedora altogether.
Comment 5 Stefan de Konink 2014-02-04 13:12:21 EST
Please people, do not feed the troll(s). Let the Fedora Counsil decide it this matter. A question has been asked, our defense has been given.
Comment 6 Tom "spot" Callaway 2014-02-04 16:43:26 EST
Stefan, since you seem to be able to speak for Cherokee, are you saying that the license terms of Cherokee do not permit the removal, modification, or replacement of the logos?
Comment 7 Stefan de Konink 2014-02-04 16:47:14 EST
I am unsure about the status of the creative works shipped with Cherokee, but am sure the distribution of sourcecode and images are shipped under the GPL version 2 [1]. Thus I am kindly requesting not to fork our project over this matter.

[1] https://github.com/cherokee/webserver/blob/master/COPYING
Comment 8 Tom "spot" Callaway 2014-02-04 17:00:31 EST
(In reply to Stefan de Konink from comment #7)
> I am unsure about the status of the creative works shipped with Cherokee,
> but am sure the distribution of sourcecode and images are shipped under the
> GPL version 2 [1]. Thus I am kindly requesting not to fork our project over
> this matter.

Okay. Your request is noted. Just wanted to be clear that you did not intend to add an additional license restriction preventing the removal or modification of those images.
Comment 9 Stefan de Konink 2014-02-04 17:18:05 EST
Hi Tom,

On github you can find the most latest stable version. I highly encourage packages to upgrade to our latest master code. Fewer bugs than ever before AND we have just incorporated code that allows a packager automatically to remove the offending artwork by running censor-artwork.py. It requires a python interpreter, but that should be available on Red Hat derived systems.

Stefan
Comment 10 Tom "spot" Callaway 2014-02-04 17:24:54 EST
Thanks for the information. That said, it seems odd that you would request that Fedora not remove the artwork from Cherokee while providing an upstream included mechanism to take this action.
Comment 11 Stefan de Konink 2014-02-04 17:36:51 EST
Actually we also discussed alternative logo designs with one of your colleagues before. Hence since I am made aware of this issue I have been very cooperative and addressing these issues in the best direction for our project. Sadly not all of your colleagues are helpful. The reporter is actively harming our open source community, therefore we did file a formal complaint at Red Hat for his actions, while collaboratively working to offer censored artwork. It is now up to the packager to package it in that way he or she sees fit.
Comment 12 Máirín Duffy 2014-02-05 12:52:23 EST
Hi Tom, I'm happy to create replacement artwork and already offered to, and Stefan even spoke to me off-list about it. Stefan, how should I proceed - do you want me to create some mockups and post them here for your review / feedback?
Comment 13 Máirín Duffy 2014-02-05 22:58:06 EST
I withdraw my offer to provide artwork to help the Cherokee project on this matter since my coworker who I respect very much has been threatened. You can find another artist, or stop with this nonsense.
Comment 14 Richard Fontana 2014-02-13 21:34:44 EST
I am closing this bug as it is likely to become moot.

Note You need to log in before you can comment on or make changes to this bug.