Bug 106121 - Fedora crashes on SMP boot
Fedora crashes on SMP boot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-10-02 18:16 EDT by Mark H Johnson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.4.22-1.2082
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-10-03 15:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mark H Johnson 2003-10-02 18:16:55 EDT
Description of problem:

Found problem w/ upgrade (already reported) - sigh. Did a fresh install, chose
items that 
would be a mix of development workstation and server packages (not everything).
was just under 3G install on a 30G system w/
 /boot - 100M
 / - 6000M
 /opt1 - the rest
 swap - 2000M
on a dual Pentium III system, 512M memory. All partitions except swap are ext3,
all were
reformatted since DIsk Druid had cautions about not doing that.

After install is complete w/o error, rebooted the system. The text dialog was
shown briefly
and replaced by the GUI showing progress on the boot. Able to move the mouse
the hourglass) until it displays
  "Setting up local disks"
when the whole machines locks up. No response to keyboard nor mouse. Tried
sequences, no change. Had to use reset button to get any resposne.

Version-Release number of selected component (if applicable):

How reproducible:

Install Fedora on a machine that was previously running RH 7.3.

Steps to Reproduce:
1.See description
Actual results:

Machine locks up  - is completely unusable.

Expected results:

System boots and displays login screen.

Additional info:

Booted single user and the last screen shown is a bug - sorry, can't see it all
due to the length
of the output but what it says is [copied by hand...]]

keybdev hid input usb-uhci-usbcore ext3 jbd
CPU: 0
EIP: 0060:[<c012becd>] Not tainted

EIP is at __run_task_queue [kernel] 0x1d (2.4.22-1.2061.nptlsmp)
eax: 00000000 ebx: 00000096 ecx: df35febc edx:00000068
esi 0000000b edi: 00000000 ebp: 00000000 esp:df35feb8
ds: 0068 es: 0068 ss: 0068
Process depmod (pid: 143, stackpage=df35f000)
Stack: df35ff28 00000020 0985b2e0 0985b2e0
 0000000b c013006d 00000068 ffffffff
 00000000 00000068 00010246 0000000b
 c0131b28 000000b df35ff28 df35e000
 00000282 0000000e df35e000 dfae4a68
 dfaa5b68 c011e254 0000000b df35ff28

Call Trace: [<c013006d>] tqueue_bh [kernel] 0x1d (0xdf35fecc)
 [<c0131b28>] force_sig_info [kernel] 0x78 (0xdf35fee8)
 [<c011e254>] do_page_fault [kernel] 0x464 (0xdf35ff0c)
 [<co140ccd>] generic_file_read [kernel] 0xbd (0xdf35ff58)
 [<c0140b10>] file_read_actor [kernel] 0x0 (0xdf35ff58)
 [<c0152ae7>] sys_read [kernel] 0x97 (0xdf35ff94)
 [<c011ddf0>] do_page_fault [kernel] 0x0 (0xdf35ffb0)
 [<c0109ff0>] error_code [kernel] 0x34 (0xdf35ffb8)

Code: 8b 02 89 48 04 89 44 24 04 8b 42 04 89 44 24 08 89 08 b0

--- yech ---

Next tried the UP kernel, it boots OK w/ UP and reached the set up page.
Comment 1 Bill Nottingham 2003-10-03 11:09:38 EDT
Please try the SMP kernel in the updates channel.
Comment 2 Mark H Johnson 2003-10-03 11:50:47 EDT
Just installed
and it works just fine. Thanks.

Note You need to log in before you can comment on or make changes to this bug.