Bug 106147 - up2date crashes when attempting to update, either graphically or from teh command line
Summary: up2date crashes when attempting to update, either graphically or from teh com...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-03 08:36 UTC by Need Real Name
Modified: 2007-04-18 16:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 19:49:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text of Python-reported error (1.64 KB, text/plain)
2003-10-03 08:42 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-10-03 08:36:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When running up2date (which I do graphically) it crashes (with a python error) 
when getting list of updates - once channels have been selected. 

De-selecting all channels allows it to complete, but of course doesn't update 
anything. 

Error message attached. Running up2date -p seems to work (doesn't give an 
error).

I searched for the bug, but the only similar case seemed to be caused by 
the 'Subscribed Channels' being empty. Not the case here.


Version-Release number of selected component (if applicable):
2.8.40-3.7.3

How reproducible:
Always

Steps to Reproduce:
1.Enter gnome
2.Run up2date
3.Select channel
    

Actual Results:  Python error appears in terminal window.
Up2date screen stays open, but does not complete. Hangs.

Expected Results:  List of updates should appear (or message 'Your system is up 
to date')

Additional info:

This problem first appeared after a disk problem forced a re-install of RH 7.1. 
I have since upgraded to 7.3 (and installed all errata from CD), but with no 
effect.

Comment 1 Need Real Name 2003-10-03 08:42:38 UTC
Created attachment 94908 [details]
text of Python-reported error

Comment 2 Need Real Name 2003-10-17 07:30:59 UTC
I have managed to get this working by modifying the supplied Python code: 
change line 115 of rhnHTTPlib.py from


h = myHTTPs(host, 0, self.__ca_chain, protocol = protocol)

to

h = myHTTPs(host, 0, self.__ca_chain)

 -  removing the last parameter entirely (leaving it to default?)

and then the connection works and downloads


Even so, it's still a bug. I shouldn't have to modify supplied code to make it 
work.


Note You need to log in before you can comment on or make changes to this bug.