Bug 1061613 - [RDO][Openstack-foreman-installer]: puppet throws errors during registration of clients against foreman-server. (during: foreman_client.sh)
Summary: [RDO][Openstack-foreman-installer]: puppet throws errors during registration...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RDO
Classification: Community
Component: openstack-foreman-installer
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Guiditta
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 08:38 UTC by Omri Hochman
Modified: 2018-05-02 10:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-12 15:40:49 UTC


Attachments (Terms of Use)
/var/log/messages (168.73 KB, text/plain)
2014-03-26 09:00 UTC, Udi
no flags Details

Description Omri Hochman 2014-02-05 08:38:14 UTC
[RDO][Openstack-foreman-installer]:  puppet throws errors during registration of clients against foreman-server. (during: foreman_client.sh)  

Environment (RDO test-day 5 Feb 2014) :
----------------------------------------
openstack-foreman-installer-1.0.3-1.el6.noarch
foreman-1.3.2-1.el6.noarch
packstack-modules-puppet-2013.2.1-0.29.dev956.el6.noarch
puppet-3.4.2-1.el6.noarch
puppet-server-3.4.2-1.el6.noarch


Steps: 
------
1) Install foreman-server. 
2) Attempt to register clientes to foreman-server by running foreman_client.sh


Results: 
---------
- the foreman_client.sh finish successfully and registered the clients well.
- there are error on the screen during the run of foreman_client.sh . 


I registered few foreman_clients and got different errors for each run :
-------------------------------------------------------------------------
Error: /File[/var/lib/puppet/lib/puppet/type/cinder_api_paste_ini.rb]/ensure: change from absent to file failed: execution expired 

Error: Could not retrieve plugin: execution expired 

Error: /File[/var/lib/puppet/lib/puppet/provider/vcsrepo/cvs.rb]/ensure: change from absent to file failed: execution expired

Error: /File[/var/lib/puppet/lib/puppet/type/neutron_network.rb]/ensure: change from absent to file failed: execution expired

Comment 1 Omri Hochman 2014-02-05 08:41:28 UTC
At first we suspected that it due to multiple clients trying to register at the same time, but then when I tried to register only 1 client, again I got this error s.

Comment 2 Omri Hochman 2014-02-05 10:30:57 UTC
Output Example : 

Notice: /File[/var/lib/puppet/lib/puppet/type/neutron_config.rb]/ensure: defined content as '{md5}9de57ffe7acea6318a5ee959d28f3bb1'
Notice: /File[/var/lib/puppet/lib/puppet/type/neutron_l3_ovs_bridge.rb]/ensure: defined content as '{md5}058d18a7e7cc88d446aa07cf25a657fe'
Notice: /File[/var/lib/puppet/lib/puppet/type/remote_database_user.rb]/ensure: defined content as '{md5}053a3c8d778e4bbddc9e75fbe36e1108'
Notice: /File[/var/lib/puppet/lib/puppet/type/qpid_user.rb]/ensure: defined content as '{md5}f104d60fc6f5f3a9f9d3ac26f11e239b'
Notice: /File[/var/lib/puppet/lib/puppet/type/heat_config.rb]/ensure: defined content as '{md5}d03d06107ec6fbb7a80cf86b238a9153'
Notice: /File[/var/lib/puppet/lib/puppet/type/database.rb]/ensure: defined content as '{md5}a5e9e5edb5aa67bbddd17fb9096c9eae'
Notice: /File[/var/lib/puppet/lib/puppet/type/nova_paste_api_ini.rb]/ensure: defined content as '{md5}6e14d1afcaf1000624459e9654c51937'
Notice: /File[/var/lib/puppet/lib/puppet/type/database_user.rb]/ensure: defined content as '{md5}3c1569f97f0b2c76437503e3d47d520b'
Notice: /File[/var/lib/puppet/lib/puppet/type/nova_network.rb]/ensure: defined content as '{md5}55336d8b66c3757353a9239199a7afdb'
Notice: /File[/var/lib/puppet/lib/puppet/type/file_line_after.rb]/ensure: defined content as '{md5}005c849db2d28e88bdb2b1a7038d420e'
Notice: /File[/var/lib/puppet/lib/puppet/type/glance_api_config.rb]/ensure: defined content as '{md5}284936c45073555368909fd964bd53ba'
Notice: /File[/var/lib/puppet/lib/puppet/type/remote_database_grant.rb]/ensure: defined content as '{md5}41391fc81e6849cc0c5dad5172312255'
Notice: /File[/var/lib/puppet/lib/puppet/type/cinder_api_paste_ini.rb]/ensure: defined content as '{md5}55163fa05e23c979b4108c223d853385'
Notice: /File[/var/lib/puppet/lib/puppet/type/neutron_network.rb]/ensure: defined content as '{md5}0d4ad607ba1f35f8e8faa319aa0a27c6'
Error: /File[/var/lib/puppet/lib/puppet/type/neutron_dhcp_agent_config.rb]/ensure: change from absent to file failed: execution expired
Error: Could not retrieve plugin: execution expired
Info: Loading facts in /var/lib/puppet/lib/facter/not_used.rb
Info: Loading facts in /var/lib/puppet/lib/facter/management_iface.rb
Info: Loading facts in /var/lib/puppet/lib/facter/packages.rb
Info: Loading facts in /var/lib/puppet/lib/facter/non_management_iface.rb
Info: Loading facts in /var/lib/puppet/lib/facter/not_management_iface.rb
Info: Loading facts in /var/lib/puppet/lib/facter/datetime.rb
Info: Caching catalog for cougar15.scl.lab.tlv.redhat.com
Info: Applying configuration version '1391595572'
Notice: Finished catalog run in 0.08 seconds
Info: Retrieving plugin

Comment 3 Jason Guiditta 2014-02-05 16:12:12 UTC
Dominic, googling this error looked like it was related to timeouts, any ideas or experience with this?

Comment 4 Dominic Cleal 2014-02-06 08:56:06 UTC
Can we get logs with timestamps perhaps (from syslog)?

Comment 5 Udi 2014-03-26 09:00:41 UTC
Created attachment 878913 [details]
/var/log/messages

I encountered the same problem. Attaching the syslog.

Comment 6 Dominic Cleal 2014-03-26 09:16:20 UTC
Thanks.  The Puppet agent is timing out while fetching plugins, which is controlled by the "configtimeout" setting in puppet.conf (defaults to 2 minutes, and is overloaded in what it claims to do).

There are a lot of plugins in this OpenStack setup, but IMO the rate at which the client is downloading them is rather slow, so I'd ensure that your puppetmaster has enough RAM and both the puppetmaster and agent have reasonable I/O performance so they can read + write the plugins to disk.

The foreman_client.sh script could increase the configtimeout setting to 5m or similar in puppet.conf to workaround the issue.  A bug could also be filed against Puppet to add a new setting to control the pluginsync timeout separately from the configtimeout, and for it to be higher by default.

Comment 7 Jason Guiditta 2014-07-21 16:37:54 UTC
Is this still an issue?

Comment 8 Jason Guiditta 2014-09-12 15:40:49 UTC
There has been no report of this issue in months, I am closing as not a bug, since we made no changes.  If the issue recurs, feel free to reopen this.

Comment 9 Amit Ugol 2018-05-02 10:52:22 UTC
closed, no need for needinfo.


Note You need to log in before you can comment on or make changes to this bug.