Bug 106176 - Please use ngettext for handling plurals in chkconfig
Please use ngettext for handling plurals in chkconfig
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: chkconfig (Show other bugs)
beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
http://developer.gnome.org/doc/tutori...
:
: 154313 (view as bug list)
Depends On:
Blocks: 106150
  Show dependency treegraph
 
Reported: 2003-10-03 10:22 EDT by Christian Rose
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 16:21:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2003-10-03 10:22:21 EDT
#: ../alternatives.c:661
#, c-format
msgid "There are %d programs which provide '%s'.\n"


It would be nice to handle singular/plural here. In that case, please use
ngettext as mentioned in
http://developer.gnome.org/doc/tutorials/gnome-i18n/developer.html#plurals.
A simple code example of code using ngettext:

  g_printf (ngettext ("Found %d file.", "Found %d files.", nbr_of_files),
nbr_of_files);
Comment 1 Bill Nottingham 2005-02-02 16:21:03 EST
Done in 1.3.14-1.
Comment 2 Bill Nottingham 2005-10-07 15:31:34 EDT
*** Bug 154313 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.