Bug 1061818 - when flavor is too small the error is not clear
Summary: when flavor is too small the error is not clear
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: RDO
Classification: Community
Component: python-django-horizon
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 16:57 UTC by Dafna Ron
Modified: 2014-06-18 08:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-18 08:34:16 UTC


Attachments (Terms of Use)
screen shot (181.14 KB, image/png)
2014-02-05 16:57 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1276696 None None None Never

Description Dafna Ron 2014-02-05 16:57:43 UTC
Created attachment 859746 [details]
screen shot

Description of problem:

when I try to run an instance with a flavor which is too small the error that I get from Horizon is no available compute found
the compute log shows that the issue is: FlavorDiskTooSmall

The error should be fixed since no available computes is a message that requires a user to call Admin while FlavorDiskTooSmall is something they can try to fix themselves.
I would also add that the flavor is X and the disk size is Y to help the user out...

Version-Release number of selected component (if applicable):

python-django-horizon-2014.1-0.2b2.fc21.noarch
openstack-nova-api-2014.1-0.11.b2.fc21.noarch
openstack-nova-compute-2014.1-0.11.b2.fc21.noarch

How reproducible:

100%

Steps to Reproduce:
1. create an image with a min disk size of 80G
2. try to run an instance using a small flavour.  
3.

Actual results:

the error we get in horizon is no compute available.
The nova log shows that it's actually a min disk size issue 

Expected results:

the error is misleading and suggests that there is a problem with the compute while the problem is actually with the selection of a flavour and can be solved in user's end without involving admin.  

Additional info: screen shot

Comment 1 Matthias Runge 2014-06-18 08:34:16 UTC
filed upstream


Note You need to log in before you can comment on or make changes to this bug.