Bug 1062023 - Atlas should have rpm macros
Summary: Atlas should have rpm macros
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: atlas
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Frantisek Kluknavsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-06 05:02 UTC by David Brown
Modified: 2014-11-12 02:37 UTC (History)
4 users (show)

Fixed In Version: atlas-3.8.4-12.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-01 16:23:33 UTC


Attachments (Terms of Use)

Description David Brown 2014-02-06 05:02:21 UTC
Description of problem:
I think it would be nice if atlas created some rpm macros to help package developers link against atlas libraries properly.

Version-Release number of selected component (if applicable):
atlas-3.8.4-11.fc20.x86_64
atlas-3.10.1-10.fc21.x86_64

How reproducible:
Very

Steps to Reproduce:
1. Try supporting a single spec file for a package across fedora/epel distributions.

Actual results:
To get a spec file to work on fedora 19,20,21 and epel 5/6 I've had to come up with the following

%if 0%{?fedora}%{?rhel} == 19
%define atlas_libs -lsatlas
%endif
%if 0%{?fedora}%{?rhel} == 20
%define atlas_libs -latlas -lcblas -lclapack -lf77blas -llapack -lptcblas -lptf77blas
%endif
%if 0%{?fedora}%{?rhel} == 21
%define atlas_libs -lsatlas
%else
%define atlas_libs -lf77blas -llapack
%endif

Expected results:
I'd much rather just have atlas_libs defined for me, or have some set of rpm macros auto-defined from pkg-config pc file.

Comment 1 Fedora Admin XMLRPC Client 2014-07-26 17:14:52 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora Admin XMLRPC Client 2014-07-28 07:46:07 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2014-07-28 07:47:18 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 David Brown 2014-10-07 00:46:34 UTC
Ping, just had to update ga package for f22 branch to get things to build properly... It'd still be nice to have this.

Comment 5 Frantisek Kluknavsky 2014-10-07 14:56:23 UTC
Hi.

Pkgconfig seems to be the right tool. Atlas-devel would contain /usr/lib64/pkgconfig/atlas.pc with contents (not tried yet):

Name: atlas
Description: Automatically Tuned Linear Algebra Software
Cflags: -I${includedir}/atlas
Libs: -L${libdir}/atlas -lsatlas

Comment 6 David Brown 2014-10-07 16:12:26 UTC
That's perfect, could I get that addition pushed to f21, f20 and el6?

Comment 7 Frantisek Kluknavsky 2014-10-07 17:52:33 UTC
F20 and F21 should be no problem. RHEL7 maybe, not sure. I am skeptical about RHEL6.

Comment 8 David Brown 2014-10-07 18:43:53 UTC
Do you need some help maintaining epel7 and el6? I can certainly be of assistance there. I'm currently a maintainer of several packages for fedora/epel.

Comment 9 Ondrej Vasik 2014-10-07 19:08:36 UTC
atlas is in base rhel, therefore it can't be in epel.

Comment 10 David Brown 2014-10-07 19:15:43 UTC
Oh, right...

Comment 11 Frantisek Kluknavsky 2014-10-23 17:15:39 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=7934539

Does it work as expected?

Comment 12 Fedora Update System 2014-10-24 15:48:23 UTC
atlas-3.10.1-15.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/atlas-3.10.1-15.fc21

Comment 13 Fedora Update System 2014-10-27 08:18:56 UTC
Package atlas-3.10.1-15.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing atlas-3.10.1-15.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13664/atlas-3.10.1-15.fc21
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2014-10-31 19:25:45 UTC
atlas-3.8.4-12.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/atlas-3.8.4-12.fc20

Comment 15 Fedora Update System 2014-11-01 16:23:33 UTC
atlas-3.10.1-15.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2014-11-12 02:37:49 UTC
atlas-3.8.4-12.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.