Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: The /var/log/mariadb/mariadb.log file is owned by root:root. systemd can't start mariadb because it uses the mysql user and is unable to write to the log file. Version-Release number of selected component (if applicable): mariadb-server-5.5.34-3.fc20.x86_64 How reproducible: 100% Steps to Reproduce: 1. Start the cloud qcow2 image at with OpenStack (via libvirt may also work): http://download.fedoraproject.org/pub/fedora/linux/releases/20/Images/x86_64/Fed ora-x86_64-20-20131211.1-sda.qcow2 2. yum -y install mariadb mariadb-server httpd wordpress 3. systemctl start mariadb.service Actual results: mariadb fails to start complaining about unable to open /var/log/mariadb/mariadb.log Expected results: mariadb starts Additional info: chown mysql.mysql /var/log/mariadb/mariadb.log resolves the problem because mysql is able to write to the file (since it is run as the mysql:mysql user). I am surprised the log file is owned by the package - I would not expect this to be the case.
(In reply to Steven Dake from comment #0) > I am surprised the log file is owned by the package - I would not expect > this to be the case. Owning the log file by a package is actually correct, but the owner really should be mysql:mysql. Anyway, this problem should be fixed by update for bug 1061045. *** This bug has been marked as a duplicate of bug 1061045 ***