Bug 106216 - Segmentation fault in Iometer (at futex call by glibc)
Segmentation fault in Iometer (at futex call by glibc)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-03 14:13 EDT by Daniel Scheibli
Modified: 2016-11-24 09:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ltrace output for the crashing executable (15.67 KB, text/plain)
2003-10-03 15:04 EDT, Daniel Scheibli
no flags Details
strace output for the crashing executable (8.91 KB, text/plain)
2003-10-03 15:05 EDT, Daniel Scheibli
no flags Details

  None (edit)
Description Daniel Scheibli 2003-10-03 14:13:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Description of problem:
I'am one of the maintainers of the Iometer
project (sourceforge.net/projects/iometer).

One of our users reported an error (segementation fault) when
running the benchmark suite with RedHat 9 (2.4.20-8 kernel).
The error is 100% reproducable on every RH9 box we have tested
so far - the strange thing is, that everything worked fine with
RH7.2 as well as RH8.0.

I did some investigations (for example ltrace / strace -> already
send to Ingo Molnar) and it seems, that the SIGSEGV signal is
raised due to an futex() call with ETIMEDOUT as return code.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start a benchmark (any kind of setup)
2.End the benchmark run (crash happens while transfering the results)


Actual Results:  The benchmark driver (executable called dynamo) crashes
with a segmentation fault.

Expected Results:  The benchmark driver continues to run until the enduser
ends it explicitely.

Additional info:

Traces have been send to Ingo Molnar
Comment 1 Jakub Jelinek 2003-10-03 14:46:38 EDT
Is the benchmark available somewhere?
If not, can the details be posted here? Also, can you reproduce it with
Fedora Core Test 2?
Without details there is nothing that can be done about it.
Comment 2 Daniel Scheibli 2003-10-03 14:57:42 EDT
The benchmark is open source and can be downloaded from
the download area of the URL provided in the initial posting:

http://sourceforge.net/projects/iometer

So far the same thing wasn't tested with Fedora Core Test 2.
If you provide me with a download URL for the needed ISO's
I will give it a try.

The strace/ltrace output again was already provided to Ingo
Molnar but if you point me to a location where to upload it
I will provide that information as well.
Comment 3 Jakub Jelinek 2003-10-03 14:59:56 EDT
The best place to upload them is this bug (so that they are recorded too).
There is the "Create a New Attachment" for exactly this purpose.
Comment 4 Daniel Scheibli 2003-10-03 15:04:46 EDT
Created attachment 94920 [details]
ltrace output for the crashing executable
Comment 5 Daniel Scheibli 2003-10-03 15:05:28 EDT
Created attachment 94921 [details]
strace output for the crashing executable
Comment 6 Daniel Scheibli 2003-10-03 15:08:06 EDT
Ok, two more information I didn't add so far:
1.) IMPORTANT: The segmentation fault can be
    prevented by using LD_ASSUME_KERNEL=2.4.1
2.) Ingo wanted me to create a bugzilla request
    (I already sent him the bug number)
Comment 7 Jakub Jelinek 2003-10-03 15:22:49 EDT
It looks like it is segfaulting somewhere in aio code in librt, at least that's
my guess.
Can you run it with LD_PRELOAD=/lib/libSegFault.so and/or ulimit -c unlimited; run the program; gdb ./the_program core*
and get backtrace etc.?
Fedora Core Test2 isos are available from ftp://ftp.redhat.com/pub/redhat/linux/beta/severn/
Also, if I were to look at it myself, I'd appreciate step by step instructions
how to run the testsuite to reproduce it.
Comment 8 Ulrich Drepper 2003-11-05 14:02:05 EST
No response in a month.  No bug has been demonstrated.  I'm closing
the bug now.  If there is something wrong and you can demonstrate it,
reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.