Bug 106218 - useradd seg faults
Summary: useradd seg faults
Status: CLOSED DUPLICATE of bug 89145
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-03 18:44 UTC by Bob T.
Modified: 2007-04-18 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace useradd kde" (15.76 KB, text/plain)
2003-10-03 18:46 UTC, Bob T.
no flags Details

Description Bob T. 2003-10-03 18:44:10 UTC
Description of problem: 
useradd (without -D) segfaults


Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-6



How reproducible:
Every time, and on two separate RH 9 boxes


Steps to Reproduce:
1.useradd anything
2.
3.
    
Actual results:
Segmentation fault (core dumped)


Expected results:
new user


Additional info:
strace to be attached

Comment 1 Bob T. 2003-10-03 18:46:42 UTC
Created attachment 94918 [details]
output of "strace useradd kde"

Comment 2 Bob T. 2003-10-03 18:47:50 UTC
rpm -V shadow-utils  is empty

Comment 3 Bob T. 2003-10-07 14:35:39 UTC
After comparing my trace with the trace of a successful useradd on another RH9
box, I conjectured that useradd was incompatible with libsafe.  And indeed,
after unsetting LD_PRELOAD, useradd no longer segfaults.  But presumably there
is unsafe  
code in useradd, which is somewhat worrisome.

Comment 4 Enrico Scholz 2003-10-08 10:05:16 UTC
Sounds like a dup of bug #89145 (which has a patch)

Comment 5 Bob T. 2003-10-08 11:59:58 UTC

*** This bug has been marked as a duplicate of 89145 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:58:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.