Bug 106220 - printer configuration tool can't find windows networked shared printer
printer configuration tool can't find windows networked shared printer
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-03 15:02 EDT by jackstoage
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen dump of printer config GUI (139.51 KB, image/png)
2003-10-03 15:13 EDT, jackstoage
no flags Details
results of smbclient -L server command (42.00 KB, text/plain)
2003-10-07 14:00 EDT, jackstoage
no flags Details
network server command response (56.78 KB, image/png)
2003-10-20 20:17 EDT, jackstoage
no flags Details
smbclient -L server response (32.89 KB, image/png)
2003-10-20 20:18 EDT, jackstoage
no flags Details
smb.conf file (10.78 KB, text/plain)
2003-10-20 20:22 EDT, jackstoage
no flags Details

  None (edit)
Description jackstoage 2003-10-03 15:02:56 EDT
Description of problem:
Linux and W2k boxes see each other through samba as "linux" and "server" and 
can transfer files. W2k box has 1 user acct "share" w/ no password (or blank 
password) and is the default logon user. Linux box has 2 user accounts "dad" 
and "share" w/ passwords. Only "dad" acct is shared though samba. HP all-in-
one R80 printer attached to W2k box and shared (and working) to other W2k 
boxes through access point router or phoneline network card (latter not 
configurable by Linux box). In W2k network neighborhood, "server" box path to 
share acct is \\server\share. Path to printer is \\server\HPOffice (caps are 
real). W2k printer properties reveals share name as "hpoffice" (no caps???). 
Print config GUI locates the "server" box but can't find the shared printer 
queue.

I am uptodate as of 10/02/03



Version-Release number of selected component (if applicable):


How reproducible:
connect to a printer using the printer configuration GUI

Steps to Reproduce:
1.Open print config GUI and choose "new".
2.Name the new queue.
3.clck next and select queue type "networked windows (SMB).
4.Tool retreaves "server" and "linux" networked host (as expected). 
5.Attempting to Expand "server" tree reveals no associated printer queues.
6.Clicking on host and then next gives error must choose a queue not a host.7.
clicking on "specify" and filling out blanks as follows:
workgroup = workgroup
server = \\server
share = \\server\HPOffice (or hpoffice)
user name = \\server\share
password = (blank)
returns same screen with same inputs and no messages of any kind but still 
dosen't find the printer and won't allow me to advance to the next step.
    
Actual results:
nothing, can't complete the process, have to cancel out.

Expected results:
Expect GUI to list the shared printers under each listed host.

Additional info:
Can the problem be in samba?
Is it the result of the acct "share" not having a password?
is it the access point/router?
is it not a compatable printer?
How do I fill out the "specify" window? using windows syntax or linux?
Comment 1 jackstoage 2003-10-03 15:13:49 EDT
Created attachment 94924 [details]
screen dump of printer config GUI

What I see.
Comment 2 Tim Waugh 2003-10-06 08:42:42 EDT
Does using 'share' as the user name, rather than '\\server\share', help?

Also, what does 'smbclient -L server' say when you run it from a terminal window
on the Linux machine?
Comment 3 jackstoage 2003-10-07 14:00:25 EDT
Created attachment 94993 [details]
results of smbclient -L server command

Hey, Tim, some new developments. I replaced the wired nic in the win box with a
dlink wireless one and logging on last night to try your suggestions was no
longer able to see the win box form the linux box. I had already set it up with
the other win boxes and there were no changes to the linux box. I hadn’t even
tried it until this moment. I could see the linux box from win box, though.
Your suggested command “smbclient –L server” failed to connect. On a whim
I added “user account = dad’ to the global settings and “public = yes”
to the printers settings of the smb.conf and restarted samba and rebooted the
win box. For whatever reason 2way communication was restore and the smbclient
–L server command found its mark (see attached). Kind a weird. It doesn’t
seem like anything should have change and the smb.conf	changes were intended
to help the printer problem not connectivity.

Anyway, I then tried to connect to the win box printer using the printer config
GUI as before and under specify, where all the problems begin, I entered the
following:

Workgroup = workgroup
Server =  \\server
Share = \\server\hpoffice (all lower case)
User name = share (as you suggested)
Password = (blank)

It found the queue and serenity has been restored. I tried so many combinations
I can’t say if I tried those exacts inputs. It’s hard to believe I did not.
Or maybe it was the changes to the smb.conf file. Either way it goes to show
that when you get it all right it’s like unclogging a drain.

By the way what does the error in the info returned by the smbclient –L
server command mean?

Thanks for the help and Hope this helps someone else too.

Jack
Comment 4 Tim Waugh 2003-10-08 07:33:50 EDT
I think that redhat-config-printer-0.3.77-1 should work with the inputs you
originally had.  It will appear in rawhide in a few hours.  Could you try it please?

Thanks.
Comment 5 jackstoage 2003-10-20 14:50:08 EDT
how do I get to rawhide? I am not familiar with it.
Comment 6 Tim Waugh 2003-10-20 17:46:23 EDT
It's at:

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS

You'll want both redhat-config-printer and redhat-config-printer-gui.
Comment 7 jackstoage 2003-10-20 20:17:30 EDT
Created attachment 95327 [details]
network server command response

pursuant to our ongoing problem I had somehow been able to establish a 2way
communication with my windows box via samba and got positive response from the
smbclient command you suggested (previously the w2k box could read files on the
rh box but not the other way around, see above). I was then able to find the
w2k printer and establish a queue and print fromt the rh box to the w2k box,
though the print config GUI did not auto detect the w2k printer, I had to use
the specify. All seemed fine.

Later I again lost 2way communication with the w2k box from rh box while again
having full communication from w2k to rh. My queue no longer works and I can't
browse the w2k box via network servers menu option. see the attached message
window I see when I try. Also see the smbclient -L server command response in
the following attachment and following that a copy of my smb.conf file.

Stumped

Jack
Comment 8 jackstoage 2003-10-20 20:18:40 EDT
Created attachment 95328 [details]
smbclient -L server response
Comment 9 jackstoage 2003-10-20 20:22:21 EDT
Created attachment 95329 [details]
smb.conf file
Comment 10 Tim Waugh 2003-10-21 05:01:29 EDT
Well, let me know what 0.3.77-1 does first.
Comment 11 jackstoage 2003-10-21 14:56:38 EDT
Went to the ftp site and hit a logon window brick wall. It would not let me 
logon as anonymous or with my username and paassword here.
Comment 12 jackstoage 2003-10-21 15:01:07 EDT
never mind. I got in.
Comment 13 jackstoage 2003-10-21 15:19:05 EDT
went there from link provided and found only 0.6.79-1. should I use that one?
Comment 14 Tim Waugh 2003-10-21 17:13:34 EDT
Yes please.
Comment 15 jackstoage 2003-10-22 16:50:26 EDT
Will get right on it. On that other issue of communicating with the w2k box 
from the rh box, my daughter was up with her wireless lap top and I found I 
can browse her shared folders from the rh box but still not the w2k box with 
the printer. I think I have a problem with that wireless nic. I think I am 
working a separate problem here.
Comment 16 jackstoage 2003-10-28 21:45:03 EST
Found my problem of not being able to browse the w2k box. I have a phoneline NIC
on it that samba didn't know what to do with. After disabling it the problem
went away. It still didn't autodetect the printer on the w2k box, but it had no
trouble finding it when I specified it even without using full paths in each
field. I will try the other print config as soon as I can.

Jack
Comment 17 Bill Nottingham 2006-08-04 16:35:55 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.