This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1062363 - Resuming Dell XPS 13 leaves the touchpad stuck in scroll mode
Resuming Dell XPS 13 leaves the touchpad stuck in scroll mode
Status: CLOSED DUPLICATE of bug 877464
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-06 12:53 EST by Luke Benstead
Modified: 2014-03-13 21:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 21:23:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luke Benstead 2014-02-06 12:53:54 EST
Description of problem:

About 80% of the time I resume my Dell XPS 13 (Sputnik) laptop the touchpad gets stuck in scroll mode. The cursor won't move, but windows will scroll up and down. The touchscreen continues to work, and apparently the buttons do too, but scroll mode stays stuck. I have two finger scrolling enabled and tap-to-click.

P.S. Sorry if this is filed against the wrong component, I took my best guess. How a non-technical user is ever supposed to find the right place to file a bug out of that massive list of components, I have no idea. /rant

Version-Release number of selected component (if applicable):

Erm...? Fedora 20?

How reproducible:

Very!

Steps to Reproduce:
1. Suspend laptop by closing the lid
2. Resume laptop
3. Try to move the cursor with the touchpad

Actual results:

Cursor is stuck, windows scroll

Expected results:

Cursor moves.
Comment 1 Luke Benstead 2014-02-18 03:49:17 EST
I've found that the bug occurs less frequently if I disable two-finger scrolling, but it does still happen, perhaps 1 in 5 suspends.

Is there any more information I can provide to help get this fixed? It's a pretty irritating bug :)
Comment 2 Peter Hutterer 2014-03-13 21:23:38 EDT
What's likely happening here is that the driver receives a SYN_DROPPED event which it doesn't handle. Not sure what to do for F20 here, but if you download and re-compile the rawhide xorg-x11-drv-synaptics source package that should fix the issue.

Cause is the same as bug 877464

*** This bug has been marked as a duplicate of bug 877464 ***

Note You need to log in before you can comment on or make changes to this bug.