Bug 1062409 - default gateway broken if NetworkManager is disabled/uninstalled
default gateway broken if NetworkManager is disabled/uninstalled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-06 15:26 EST by René Genz
Modified: 2014-10-07 10:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-44.git20131003.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-06 08:06:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description René Genz 2014-02-06 15:26:11 EST
Description of problem:
network connection to computers outside the subnet is not possible, if NetworkManager is disabled/uninstalled.

Version-Release number of selected component (if applicable):
NetworkManager.x86_64   1:0.9.9.0-28.git20131003.fc20

How reproducible:
100%

Steps to Reproduce:
1. kickstart text-only installation with static IPv4 adress assignment (IPv6 disabled); uninstall NetworkManager in %post section
2. after installation:
$ cd /etc/sysconfig/network-scripts/
$ cat ifcfg-em1
...
IPADDR0=<IPv4 adress>
PREFIX0=22
GATEWAY0=<IPv4 gateway adress>

$ sed -i 's/0=/=/' ifcfg-em1

$ cat ifcfg-em1
...
IPADDR=<IPv4 adress>
PREFIX=22
GATEWAY=<IPv4 gateway adress>

$ systemctl restart network.service
#and everything works fine again


Actual results:
not possible to open external website with firefox

Expected results:
being able to open external website with firefox

Additional info:
This is a repost of bug 911949 because I could not change the Fedora version.
Comment 1 Jirka Klimes 2014-08-29 03:01:44 EDT
It is fixed in Fedora 21 - bug 771673.
Comment 2 C.M. Connelly 2014-09-04 21:26:09 EDT
This problem is also seen in RHEL 7.
Comment 3 Dan Williams 2014-09-04 21:53:30 EDT
(In reply to C.M. Connelly from comment #2)
> This problem is also seen in RHEL 7.

RHEL7 is already handled by bug 1105770.
Comment 4 Fedora Update System 2014-09-04 23:07:22 EDT
NetworkManager-0.9.9.0-44.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-44.git20131003.fc20
Comment 5 Fedora Update System 2014-09-09 18:22:28 EDT
Package NetworkManager-0.9.9.0-44.git20131003.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-44.git20131003.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10460/NetworkManager-0.9.9.0-44.git20131003.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-09-12 10:29:45 EDT
NetworkManager-0.9.9.0-44.git20131003.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 René Genz 2014-10-02 09:10:17 EDT
I am using NetworkManager-0.9.9.0-45.git20131003.fc20.
If NetworkManager is uninstalled and you restart your F20 machine, connections to computers outside of local network is not possible. A simple ping will fail.

I suspect the reason is '/etc/sysconfig/network-scripts/ifcfg-em1' still uses GATEWAY0

sed -i 's/0=/=/' ifcfg-em1
systemctl restart network.service
is a workaround.

Shall I open a bug for a different package? Which package to blame?
Comment 8 Jirka Klimes 2014-10-06 08:06:45 EDT
The problem of writing GATEWAY has been fixed in NetworkManager-0.9.9.0-44.git20131003.fc20.

However, if there are old files with GATEWAY0, they need to be fixed as you did when you use legacy network.service.
Comment 9 René Genz 2014-10-07 10:46:52 EDT
sorry, I left out important information in my previous post:
I reinstalled my computer. There were no leftover files from previous installation.

The reinstallation was performed with a kickstart text-only installation.
It was initiated with a F20 USB thumb drive that was loaded with Fedora-20-x86_64-netinst.iso.
An update repo is specified. It is accessible and works.
The kickstart file contains static IPv4 adress assignment; IPv6 is disabled; NetworkManager package is uninstalled in %post section of kickstart file.


After installation '/etc/sysconfig/network-scripts/ifcfg-em1' contains GATEWAY0.
NetworkManager-0.9.9.0-45.git20131003.fc20 is the version that was available in the update repo.

Note You need to log in before you can comment on or make changes to this bug.