Bug 1062508 - Spell check changes are not saved after replacement
Summary: Spell check changes are not saved after replacement
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Usability   
(Show other bugs)
Version: unspecified
Hardware: Unspecified Unspecified
medium
high
Target Milestone: ---
: 3.4
Assignee: Patrick Huang
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
: 1024130 (view as bug list)
Depends On:
Blocks: 1088122
TreeView+ depends on / blocked
 
Reported: 2014-02-07 06:16 UTC by Leticia
Modified: 2015-07-30 01:20 UTC (History)
8 users (show)

Fixed In Version: git-server-3.3.1-257-gb0acc77
Doc Type: Bug Fix
Doc Text:
Story Points: 3
Clone Of:
Environment:
Last Closed: 2014-07-17 06:39:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Toggle syntax highlighter" was not shown in attention menu (211.86 KB, image/png)
2014-05-02 06:26 UTC, Ding-Yi Chen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1024130 None None None Never

Description Leticia 2014-02-07 06:16:47 UTC
Description of problem:
When using spell check tool, the replaced word suggested by it does not take place after leaving Zanata page. So, even when this word is fixed at the time, after leaving Zanata page, the changes don't take place 

Version-Release number of selected component (if applicable):
All projects located at https://translate.jboss.org/webtrans/translate

How reproducible:
Replacing a word suggested by the spell checker

Steps to Reproduce:
1. Replace a word through spell checker suggestion
2. Leave the Zanata page
3. Return to the same page and check again the string where the word was originally replaced

Actual results:
The word suggested by spelling check is NOT replaced

Expected results:
The word suggested by spelling check is replaced


Additional info:

Comment 1 Damian Jansen 2014-02-13 02:41:55 UTC
https://github.com/marijnh/CodeMirror/issues/1017

Comment 2 Damian Jansen 2014-02-13 05:44:41 UTC
This feature does not work, and is also damaging to user data (presenting the correct data but failing to save it).
The underlying technology - CodeMirror - does not receive a notification that something has changed. The best course of action is to set the plain text to default and codemirror as an option, but with caveats (no spell check).

Comment 3 Ding-Yi Chen 2014-02-13 06:21:06 UTC
"Setting plain text as default", IMHO, only apply for new users.

Do we have any plan to migrate the existing users?

Comment 4 Damian Jansen 2014-02-14 00:14:49 UTC
There's no migration - it's not a data issue. It's a presentation issue that, if someone desperately needs the tag highlighting for, can enable if desired.

Comment 5 Sean Flanigan 2014-02-14 01:35:20 UTC
I just hope the users of the codemirror editor don't assume that the lack of red underlines means that their spelling is perfect.

Comment 6 Ding-Yi Chen 2014-02-14 01:46:10 UTC
(In reply to Damian Jansen from comment #4)
> There's no migration - it's not a data issue. It's a presentation issue
> that, if someone desperately needs the tag highlighting for, can enable if
> desired.

Problem is, even when you change default, it does not help the existing users.
How do you tell the existing users that spell check does not work with Code mirror?

Comment 7 Patrick Huang 2014-03-05 22:46:39 UTC
https://github.com/zanata/zanata-server/pull/379

Comment 8 David Mason 2014-03-26 02:18:41 UTC
Changes discussed in meeting:

 - remove option to enable or disable spellchecking
 - restore option to use syntax highlighting editor (use user preference)
    - option does not need to be saved automatically when toggling with the tooltip
 - show warnings as tooltip on the syntax highlighting editor selection option (and optionally as a popup), warning about:
    - spellcheck issues with syntax highlighting editor
    - unicode issues with syntax highlighting editor

Comment 9 Sean Flanigan 2014-03-26 04:42:52 UTC
(In reply to David Mason from comment #8)
> Changes discussed in meeting:
> 
>  - remove option to enable or disable spellchecking

(because spellcheck will be permanently disabled for codemirror)

>  - restore option to use syntax highlighting editor (use user preference)
>     - option does not need to be saved automatically when toggling with the
> tooltip

Toggling with the tooltip???

Using the keyboard shortcut should toggle the option in the editor options panel.

Option does not need to be auto-saved as a user preference *as part of this story*.

>  - show warnings as tooltip on the syntax highlighting editor selection
> option (and optionally as a popup), warning about:

We shouldn't hide the warnings behind a tooltip; we should add an extra line if we need it.

>     - spellcheck issues with syntax highlighting editor

actually no spell check at all
 
>     - unicode issues with syntax highlighting editor

I imagined something like 
[x] use syntax-highlighting editor
    (Not recommended: no spellcheck, some Unicode issues)

Which reminds me: we should have analytics to find out how often codemirror is actually used.  But not as part of this story.

Comment 10 Patrick Huang 2014-05-01 01:16:55 UTC
https://github.com/zanata/zanata-server/pull/379

Comment 11 Patrick Huang 2014-05-01 01:30:57 UTC
as a workaround, user now is able to use ctrl-alt-h or ctrl-x then h to toggle between syntax highlight or plain text editor for current active row. It's a lot quicker to access good/working parts of both editor.

Comment 12 Patrick Huang 2014-05-02 01:37:30 UTC
comment 11 has an error. the shortcut will be ctrl-alt-h or alt-x then h.

Comment 13 Ding-Yi Chen 2014-05-02 06:12:11 UTC
Tested with Zanata 3.4.0-SNAPSHOT (git-server-3.3.1-250-gfd7452f)

The functionality is there, however,

After pressing alt-x, the 'h' did not show in attention dialog.

Reassigned.

Comment 14 Ding-Yi Chen 2014-05-02 06:26:25 UTC
Created attachment 891721 [details]
"Toggle syntax highlighter" was not shown  in attention menu

Comment 15 Patrick Huang 2014-05-05 00:22:45 UTC
fixed in latest commit

Comment 16 Ding-Yi Chen 2014-05-05 01:57:25 UTC
VERIFIED with Zanata 3.4.0-SNAPSHOT (git-server-3.3.1-257-gb0acc77)

Comment 17 Ding-Yi Chen 2014-05-05 05:23:25 UTC
*** Bug 1024130 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.