Bug 1062661 - Customer has purchased an 8246-L1D. It has an 8-core Power7+ processor and is similar to a 710 that contains 8 cpu's on one socket. The system is not subscribing correctly, and detecting a higher socket count in RHSM. I
Summary: Customer has purchased an 8246-L1D. It has an 8-core Power7+ processor and is...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.5
Hardware: ppc64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Adrian Likins
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1159926 1004793 rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-02-07 16:12 UTC by Aaron Thomas
Modified: 2018-12-09 17:29 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-16 13:42:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 119375 None None None Never

Description Aaron Thomas 2014-02-07 16:12:41 UTC
Customer has purchased an 8246-L1D. It has an 8-core Power7+ processor and is similar to a 710 that contains 8 cpu's on one socket. The system is not subscribing correctly, and detecting a higher socket count in RHSM. I


This is reproducible on customer's server, by registering the system and removing and registering the system again. 


The hardware is linux specific, has one socket and consistently shows 4 sockets on RHSM.


Additional info
-----------------------------------------

[root@powervc ~]# subscription-manager list --available --all
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:Red Hat Enterprise Linux for IBM PowerLinux Servers, Standard (1-2 sockets) (unlimited guests/LPARs) (L3-only)
Provides:Red Hat Beta
Red Hat Enterprise Linux for IBM POWER
Red Hat Enterprise Linux 7 for IBM POWER Public Beta
SKU:RH0379697
Pool ID:8a85f98142cc2b230142ce5c2b8d204e
Available:1
Suggested:1
Service Level:STANDARD
Service Type:L3
Multi-Entitlement:No
Ends:11/18/2014
System Type:Physical

Subscription Name:Red Hat Ready Business Partner Self-Supported NFR
Provides:Red Hat Software Collections Beta (for RHEL Workstation)
Red Hat Enterprise Linux Scalable File System (for RHEL Server)
Red Hat Software Collections (for RHEL Workstation)
Red Hat Software Collections (for RHEL Server)
Red Hat Enterprise Linux Workstation
Red Hat Developer Toolset (for RHEL HPC Node)
Red Hat Beta
Red Hat Software Collections Beta (for RHEL Client)
Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Red Hat Software Collections (for RHEL Client)
Red Hat Enterprise Linux High Availability (for RHEL Server)
Red Hat Enterprise Linux Server
Red Hat Software Collections Beta (for RHEL Server)
Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Red Hat Developer Toolset (for RHEL Workstation)
Red Hat Hardware Certification Test Suite
Red Hat Developer Toolset (for RHEL Client)
Red Hat Developer Toolset (for RHEL Server)
SKU:SER0403
Pool ID:8a85f9823cf494b3013df56978373849
Available:3
Suggested:1
Service Level:Self-Support
Service Type:L1-L3
Multi-Entitlement:No
Ends:04/09/2014
System Type:Physical

Comment 6 Ken Hitchcock 2014-03-11 16:36:40 UTC
I have been sent a similar issue as per below. But this time its on a Citrix XenServer. 

As up to RHEL 6.3 (kernel-2.6.32-220.el6.x86_64) the subscription-manager command would return the following:
 
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
 
ProductName:            Red Hat Enterprise Linux Server
Version:                6.3
Arch:                   x86_64
Status:                 Subscribed
Starts:                 08/01/2012
Expires:                08/01/2015
 
As of RHEL 6.4 (kernel-2.6.32-358.18.1.el6.x86_64) the subscription-manager command would return the following:
 
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux Server
Product ID:     69
Version:        6.4
Arch:           x86_64
Status:         Partially Subscribed
Status Details: Only covers 2 of 8 sockets.
Starts:         08/01/2012
Ends:           08/01/2015
 
Our current pool’s description is as follows:
 
Subscription Name: Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Unlimited guests)

Comment 7 Adrian Likins 2014-03-27 15:36:31 UTC
(In reply to Ken Hitchcock from comment #6)
> I have been sent a similar issue as per below. But this time its on a Citrix
> XenServer. 
> 

> Status:         Partially Subscribed
> Status Details: Only covers 2 of 8 sockets.


I suspect this (incorrect socket count on Xen) is more likely related to https://bugzilla.redhat.com/show_bug.cgi?id=844532


This bug (1062661) seems to be ppc46 LPAR specific.

Comment 8 Adrian Likins 2014-03-27 16:45:22 UTC
I think this is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1070908

ppc64 lpar systems add a /sys/devices/system/cpu/cpu* entry for each cpu thread available to the physical system (regardless if they are associated with that lpar). Code was previously assuming a cpu* entry meant a cpu available to the system (similar to other arches). But that is not true for ppc64 lpar systems.

The fix for 1070908 is to ignore cpu* entries that do not provide any cpu topology information. With that change, the count of cpu threads drops to 8, and
the topo info is calculated as:


'cpu.core(s)_per_socket' : '1'
'cpu.cpu(s)' : '8'
'cpu.cpu_socket(s)' : '2'
'cpu.thread(s)_per_core' : '4'
'cpu.topology_source' : 'kernel /sys cpu sibling lists'


Now, this is where things get complicated. For what the kernels considers a 'socket', that is a 2 socket machine. IBM, however, considers that a single socket (by a different definition of socket) machine.

Comment 10 Brent Baude 2014-05-06 20:16:15 UTC
Can RH provide the patch for this and also a test package?

Comment 11 John Jarvis 2014-05-09 19:51:49 UTC
IBM is signed up to test and provide feedback, setting OtherQA.

Comment 18 Joseph Kachuck 2014-12-02 14:46:43 UTC
Hello IBM,
Please confirm if you would be able to run:
# yum update subscription-manager
on RHEL 6.6 install.

Then test if this issue has been corrected.

Thank You
Joe Kachuck

Comment 19 Joseph Kachuck 2014-12-02 14:48:09 UTC
Hello IBM,
This should be fixed in subscription-manager-1.12.14-7.el6 and above.

Thank You
Joe Kachuck

Comment 20 John Sefler 2014-12-16 13:42:38 UTC
As stated in the comments above, this issue should already be addressed by the fix for bug 1070908 and is available in subscription-manager-1.11.2-1 and newer.  RHEL 6.6 was released with subscription-manager-1.12.14-7.el6 which includes the fix.  Please re-open if the problem continues after running...

yum update subscription-manager
subscription-manager facts --update


Note You need to log in before you can comment on or make changes to this bug.