Bug 1062783 - virt-manager cannot work remotely when adding physical drive to VM
Summary: virt-manager cannot work remotely when adding physical drive to VM
Keywords:
Status: CLOSED DUPLICATE of bug 557107
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-08 00:21 UTC by Paul Wouters
Modified: 2014-02-08 01:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-08 01:35:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Wouters 2014-02-08 00:21:34 UTC
Description of problem:

When running virt-manager on machine A and opening a connection to machine B, to add a VM on machine B, one cannot add a disk or partition (eg /dev/hde) because virt-manager does not allow "browse local" when connecting remotely. It also does not allow typing in "/dev/hde" for the disk image on the remote server.

Comment 1 Paul Wouters 2014-02-08 00:22:19 UTC
using ssh -X machineB and then running virt-manager locally works around the problem, but is terribly slow, even when machine A and machine B are on the same LAN.

Comment 2 Cole Robinson 2014-02-08 01:35:29 UTC
There is no way to make 'browse local' work over a remote connection. However, next version of virt-manager will try to use libvirt storage APIs to at least make typing in /dev/hde work.

*** This bug has been marked as a duplicate of bug 557107 ***


Note You need to log in before you can comment on or make changes to this bug.